dev-python/pyblake2: Bump to 1.1.0 (with impl from CPython)
authorMichał Górny <mgorny@gentoo.org>
Fri, 24 Nov 2017 17:49:43 +0000 (18:49 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 24 Nov 2017 17:53:57 +0000 (18:53 +0100)
Update the package to the new release that features implementation
copied from CPython git. This will hopefully solve all the optimization
problems reported.

Bug: https://bugs.gentoo.org/show_bug.cgi?id=638428

dev-python/pyblake2/Manifest
dev-python/pyblake2/pyblake2-1.1.0.ebuild [new file with mode: 0644]

index c76df396e8977dcd813f2e99d5ee01ee58f6264d..8cc64e2ed7354f622104f5fbadef122ab956690a 100644 (file)
@@ -1,2 +1,3 @@
 DIST pyblake2-0.9.3.tar.gz 130641 SHA256 626448e1fe1cc01d2197118954bec9f158378577e12686d5b01979f7f0fa2212 SHA512 6336a7f7e79bd3e6ff7f8ff4d279ae170e86f1464b9fa9e7ea7f0dbbac6fcc044caf225111e065f9cd9cdeea0f81fae8d373e1f65be3e418929f53fad063205e WHIRLPOOL 0d8f2aaf35a5eb0ebdedd9219a0ee8b126c93b11ae3e406ef637d8930a34783886b212ce50a33d677b0a19289cd32f40dc3da22a9a9fec108b481268f153d45b
 DIST pyblake2-1.0.1.tar.gz 128037 SHA256 c969e13d0a96c6fe843bc0b94302f7a90d66c4a5df09d7f3593edb0a9c23749d SHA512 66311aa1cd60942d395c1cd8b996f66f1cb2380f36be471244152a885cee115a8e341a34309520d8b1254eb30d5e1b39b83f89d7eace9353c8ee9e919f4a3881 WHIRLPOOL 613e2706701085e2a7895a02d08235ceecb8313f719ac88ed3beb12a59ad7483061ccb9bdba3ce8b270f973dbac9302def423037608312648fe2b3fb6d672667
+DIST pyblake2-1.1.0.tar.gz 125855 SHA256 3a850036bf42053c74bfc52c063323ca78e40ba1f326b01777da5750a143631a SHA512 e13c7e4f3a35155cbf531e337895349ec01f0ac36908a4e746cecec063601adfc8a73a7961a9c310d01d3231f44f08d2cc92e891e9cb87659bc7170b9fee6102 WHIRLPOOL 48e030a35024f4dd478607d2301d53ec2e3635fe0f5e0899270ea41dc01b3f85afc4bf01ab4d2bf44c7ba1e35c88ec94f7e975d27c37e42527320fa09d5a761f
diff --git a/dev-python/pyblake2/pyblake2-1.1.0.ebuild b/dev-python/pyblake2/pyblake2-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..82867be
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy )
+inherit distutils-r1
+
+DESCRIPTION="BLAKE2 hash function extension module"
+HOMEPAGE="https://github.com/dchest/pyblake2 https://pypi.python.org/pypi/pyblake2"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+# pyblake2 itself allows more licenses but blake2 allows the following three
+LICENSE="|| ( CC0-1.0 openssl Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+python_test() {
+       "${EPYTHON}" test/test.py || die "Tests fail with ${EPYTHON}"
+}