sys-libs/glibc: disable container tests, bug #712356
authorSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Mar 2020 13:50:35 +0000 (13:50 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sun, 15 Mar 2020 13:50:47 +0000 (13:50 +0000)
sandbox is not very compatible with filesystem unshare().
It can't check if mkdir(/proc) is a safe operation under
unshare/chroot. Let's disable container tests.

One day we can enable them if not running under sandbox.

Shoul deal with the following test failures:

    FAIL: elf/tst-dlopen-self-container
    FAIL: elf/tst-dlopen-tlsmodid-container
    FAIL: elf/tst-ifunc-fault-bindnow
    FAIL: elf/tst-ifunc-fault-lazy
    FAIL: elf/tst-ldconfig-bad-aux-cache
    FAIL: elf/tst-ldconfig-ld_so_conf-update
    FAIL: elf/tst-pldd

Reported-by: Toralf Förster
Bug: https://bugs.gentoo.org/712356
Package-Manager: Portage-2.3.94, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/glibc/glibc-2.31-r1.ebuild
sys-libs/glibc/glibc-9999.ebuild

index 73704b785a2d897a7e2322172bddacc82db307e1..d303115a4a6d64774705a474f7a150b8d081c04f 100644 (file)
@@ -1137,7 +1137,11 @@ src_compile() {
 
 glibc_src_test() {
        cd "$(builddir nptl)"
-       emake check
+       # disable tests:
+       # - tests-container:
+       #     sandbox does not understand unshare() and prevents
+       #     writes to /proc/
+       emake check tests-container=
 }
 
 do_src_test() {
index a457c751d18dc9bcaeda8e9b6db32e00093062c6..229af08f2ca8d2519885cb0a419279e63c9b19d9 100644 (file)
@@ -1136,7 +1136,11 @@ src_compile() {
 
 glibc_src_test() {
        cd "$(builddir nptl)"
-       emake check
+       # disable tests:
+       # - tests-container:
+       #     sandbox does not understand unshare() and prevents
+       #     writes to /proc/
+       emake check tests-container=
 }
 
 do_src_test() {