app-text/xchm: fdo-mime->xdg-utils
authorMarty E. Plummer <hanetzer@startmail.com>
Sun, 8 Apr 2018 14:18:43 +0000 (09:18 -0500)
committerDavid Seifert <soap@gentoo.org>
Fri, 20 Apr 2018 20:37:15 +0000 (22:37 +0200)
Package-Manager: Portage-2.3.28, Repoman-2.3.9

app-text/xchm/xchm-1.23-r1.ebuild
app-text/xchm/xchm-1.23-r2.ebuild

index e5813683f6fe86250b9b46024493edf4680ff0d8..26b4e3e15f865fdb0ee67e7e17ae2129a7189765 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="5"
 WX_GTK_VER="3.0"
 
-inherit eutils fdo-mime flag-o-matic wxwidgets
+inherit eutils flag-o-matic wxwidgets xdg-utils
 
 DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
 HOMEPAGE="http://xchm.sourceforge.net/"
@@ -40,11 +40,11 @@ src_install() {
 }
 
 pkg_postinst() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
 }
 
 pkg_postrm() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
 }
index b9eaf64c963e70e28ea5af089f052629fb267536..f7ee063880c73ad98c46664d81dfdda8b83f1f35 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
 WX_GTK_VER="3.0-gtk3"
 
-inherit fdo-mime wxwidgets
+inherit wxwidgets xdg-utils
 
 DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
 HOMEPAGE="http://xchm.sourceforge.net/"
@@ -41,11 +41,11 @@ src_install() {
 }
 
 pkg_postinst() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
 }
 
 pkg_postrm() {
-       fdo-mime_desktop_database_update
-       fdo-mime_mime_database_update
+       xdg_desktop_database_update
+       xdg_mimeinfo_database_update
 }