media-sound/bplay: Port to EAPI 7
authorDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 11:39:33 +0000 (13:39 +0200)
committerDavid Seifert <soap@gentoo.org>
Wed, 16 Oct 2019 11:39:33 +0000 (13:39 +0200)
Bug: https://bugs.gentoo.org/697274
Package-Manager: Portage-2.3.77, Repoman-2.3.17
Signed-off-by: David Seifert <soap@gentoo.org>
media-sound/bplay/bplay-0.991.ebuild

index 2352a1b522c3b22d2659b7f115de8d41ba291932..0fe9c8a2443a283b5adee4bcdb6c367402e716dd 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
+EAPI=7
 
 inherit toolchain-funcs
 
@@ -12,17 +12,18 @@ SRC_URI="http://www.amberdata.demon.co.uk/bplay/${P}.tar.gz"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 hppa ~ppc sparc x86"
-IUSE=""
 
 src_compile() {
-       emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}" \
-               CFLAGS="${CFLAGS} -DUSEBUFFLOCK" bplay || die "emake failed"
+       emake \
+               LDFLAGS="${LDFLAGS}" \
+               CFLAGS="${CFLAGS} -DUSEBUFFLOCK" \
+               CC="$(tc-getCC)" bplay
 }
 
 src_install () {
-       newbin bplay bplay-bin || die "dobin failed"
-       dosym bplay-bin /usr/bin/brec || die "dosym failed"
+       newbin bplay bplay-bin
+       dosym bplay-bin /usr/bin/brec
        doman brec.1
        newman bplay.1 bplay-bin.1
-       dodoc README
+       einstalldocs
 }