dev-ada/langkit: fix usage of pyyaml
authorTupone Alfredo <tupone@gentoo.org>
Thu, 26 Mar 2020 19:50:28 +0000 (20:50 +0100)
committerTupone Alfredo <tupone@gentoo.org>
Thu, 26 Mar 2020 19:50:28 +0000 (20:50 +0100)
Closes: https://bugs.gentoo.org/713340
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ada/langkit/files/langkit-2019-pyyaml.patch [new file with mode: 0644]
dev-ada/langkit/langkit-2018.ebuild
dev-ada/langkit/langkit-2019.ebuild

diff --git a/dev-ada/langkit/files/langkit-2019-pyyaml.patch b/dev-ada/langkit/files/langkit-2019-pyyaml.patch
new file mode 100644 (file)
index 0000000..58a6499
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/testsuite/testsuite_support/polyfill.py  2020-03-26 20:43:40.861154768 +0100
++++ b/testsuite/testsuite_support/polyfill.py  2020-03-26 20:44:07.874675123 +0100
+@@ -376,7 +376,7 @@
+         # First load data provided by this testcase
+         try:
+             with open(os.path.join(test_dir, 'test.yaml'), 'r') as f:
+-                test_data = yaml.load(f)
++                test_data = yaml.safe_load(f)
+         except (IOError, yaml.error.YAMLError) as exc:
+             status = 'PROBLEM'
+             message = 'Invalid test.yaml: {}'.format(exc)
index 348ef449845aa5e876967f871ba6d14728f2b742..743c42e819dd1fa129383f7764b26adadc45a526 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -24,7 +24,6 @@ DEPEND="${PYTHON_DEPS}
        dev-ada/gnatcoll-bindings[iconv,shared]
        dev-python/mako
        dev-python/pyyaml
-       <dev-python/pyyaml-5
        dev-python/enum34
        dev-python/funcy
        dev-python/docutils
@@ -33,7 +32,10 @@ RDEPEND="${DEPEND}"
 
 S="${WORKDIR}"/${MYP}-src
 
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+       "${FILESDIR}"/${P}-gentoo.patch
+       "${FILESDIR}"/${PN}-2019-pyyaml.patch
+)
 
 src_test() {
        testsuite/testsuite.py -j $(makeopts_jobs) --show-error-output | tee testsuite.log
index 229fdd526dcc2898292f18030d702b1e535bd1cd..31a57f6edd4469c7b909ad47ca9ec225f8ddaac5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -24,7 +24,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
 RDEPEND="${PYTHON_DEPS}
        dev-ada/gnatcoll-bindings[iconv,shared]
        dev-python/mako
-       <dev-python/pyyaml-5
+       dev-python/pyyaml
        dev-python/enum34
        dev-python/funcy
        dev-python/docutils"
@@ -34,7 +34,10 @@ DEPEND="${RDEPEND}
 
 S="${WORKDIR}"/${MYP}-src
 
-PATCHES=( "${FILESDIR}"/${P}-gentoo.patch )
+PATCHES=(
+       "${FILESDIR}"/${P}-gentoo.patch
+       "${FILESDIR}"/${P}-pyyaml.patch
+)
 
 src_test() {
        testsuite/testsuite.py -j $(makeopts_jobs) --show-error-output | tee testsuite.log