dev-php/symfony-dependency-injection: new version 2.8.20.
authorMichael Orlitzky <mjo@gentoo.org>
Thu, 4 May 2017 12:45:49 +0000 (08:45 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Thu, 4 May 2017 12:45:49 +0000 (08:45 -0400)
This new version spells out all of the source code directories to be
installed, thereby avoiding the installation of junk like
composer.json. I've also left a comment stating that I'm not so sure
about some of the RDEPEND entries...

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-php/symfony-dependency-injection/Manifest
dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.20.ebuild [moved from dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.15.ebuild with 54% similarity]

index 15dd02ab427db2ca144384c0579fde9e7cf26b19..3220a7fd0eb10da7f50cd36e7f2e29ceab974cba 100644 (file)
@@ -1 +1 @@
-DIST symfony-dependency-injection-2.8.15.tar.gz 116157 SHA256 923e0693d1d629a09876b654663246911398a8262c7e1e7558a14ba0b1aa1fc9 SHA512 232d88c6740166b087991fb43f5dc4b93b9770cc570760336049035a037901017076891f61516281e74e60a15e78b4d836a5741246965e9def047b5e4ce6bb8d WHIRLPOOL 00973393cec3d4669117f848c954e3fecb438b405e73afe7d4163d9d21a7980981f9f226f731ccafe85aa334ece738588b168e25de7259b7d624ccb0a0c672a6
+DIST symfony-dependency-injection-2.8.20.tar.gz 117123 SHA256 ff71fe1b93ff2020d59ffae4017fcb3858563e4a8a9002011a639db6c38a8a39 SHA512 9ab6a4b36fde3908f26c2211066df501dd73387a7ec3d0aae85f8289257653bb54393bd9f4b50c347a4d5ba47214f13c089e475eaace3868f5c18f67b69bd829 WHIRLPOOL cf46966bda4af047cd9aa4d3b6c3063c9404b46d6948f14a6fe33852191554e79c8858ca6c47467ab2c760555443a53c970df0baac179bc54543aef519e0cd92
similarity index 54%
rename from dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.15.ebuild
rename to dev-php/symfony-dependency-injection/symfony-dependency-injection-2.8.20.ebuild
index 021e996a96e466e62492106b682ef58c42ac55df..9b26caf5c58d299ea48e995e3e7deec8a785dd45 100644 (file)
@@ -12,33 +12,34 @@ LICENSE="MIT"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="test"
-RESTRICT="test"
 
-RDEPEND="
-       dev-lang/php:*
+# The test suite requires the unpackaged symfony-expression-language.
+RESTRICT=test
+
+# I'm not sure if symfony-config and symfony-yaml are actually needed if
+# you're not running the test suite...
+RDEPEND="dev-lang/php:*
        dev-php/fedora-autoloader
        >=dev-php/symfony-config-2.1.0
        >=dev-php/symfony-yaml-2.1.0"
-DEPEND="
-       test? (
-               ${RDEPEND}
-               dev-php/phpunit )"
+DEPEND="test? ( ${RDEPEND} >=dev-php/phpunit-5.7.15 )"
 
 S="${WORKDIR}/dependency-injection-${PV}"
 
 src_prepare() {
        default
        if use test; then
-               cp "${FILESDIR}"/autoload.php "${S}"/autoload-test.php || die
+               cp "${FILESDIR}/autoload.php" "${S}/autoload-test.php" || die
        fi
 }
 
 src_install() {
        insinto "/usr/share/php/Symfony/Component/DependencyInjection"
-       doins -r . "${FILESDIR}"/autoload.php
-       dodoc README.md
+       doins -r Compiler Dumper Exception Extension LazyProxy Loader ParameterBag
+       doins *.php "${FILESDIR}/autoload.php"
+       dodoc CHANGELOG.md README.md
 }
 
 src_test() {
-       phpunit --bootstrap "${S}"/autoload-test.php || die "test suite failed"
+       phpunit --bootstrap "${S}/autoload-test.php" || die 'test suite failed'
 }