Version bump, closes bug#158707, thanks to Walter Meinl
authorAlon Bar-Lev <alonbl@gentoo.org>
Thu, 21 Dec 2006 22:14:47 +0000 (22:14 +0000)
committerAlon Bar-Lev <alonbl@gentoo.org>
Thu, 21 Dec 2006 22:14:47 +0000 (22:14 +0000)
Package-Manager: portage-2.1.1-r2

dev-libs/nspr/ChangeLog
dev-libs/nspr/files/digest-nspr-4.6.4 [new file with mode: 0644]
dev-libs/nspr/nspr-4.6.4.ebuild [new file with mode: 0644]
dev-libs/nss/ChangeLog
dev-libs/nss/files/digest-nss-3.11.4 [new file with mode: 0644]
dev-libs/nss/nss-3.11.4.ebuild [new file with mode: 0644]

index 99274dde160ca1e6fee3b9c470f459ebd118d35f..cfa66c23b2b3d6fa9da081716465591996c51f38 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/nspr
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.59 2006/10/10 12:15:26 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/ChangeLog,v 1.60 2006/12/21 22:13:23 alonbl Exp $
+
+*nspr-4.6.4 (21 Dec 2006)
+
+  21 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org> +nspr-4.6.4.ebuild:
+  Version bump, closes bug#158707, thanks to Walter Meinl
 
 *nspr-4.6.3-r1 (10 Oct 2006)
 
diff --git a/dev-libs/nspr/files/digest-nspr-4.6.4 b/dev-libs/nspr/files/digest-nspr-4.6.4
new file mode 100644 (file)
index 0000000..bda30b2
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 43db60ab2ff1599c17d3a3f55caa7d47 nspr-4.6.4.tar.gz 1301886
+RMD160 d893554bc49c13787ec33bd2c7580f51bf8e89ac nspr-4.6.4.tar.gz 1301886
+SHA256 49e12321adb3eacf8dac5f799ab52fb1a797021fcb2893736e7bfbd517a02413 nspr-4.6.4.tar.gz 1301886
diff --git a/dev-libs/nspr/nspr-4.6.4.ebuild b/dev-libs/nspr/nspr-4.6.4.ebuild
new file mode 100644 (file)
index 0000000..821ee1c
--- /dev/null
@@ -0,0 +1,98 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nspr/nspr-4.6.4.ebuild,v 1.1 2006/12/21 22:13:23 alonbl Exp $
+
+inherit eutils gnuconfig
+
+DESCRIPTION="Netscape Portable Runtime"
+HOMEPAGE="http://www.mozilla.org/projects/nspr/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/nspr/releases/v${PV}/src/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="ipv6 debug"
+
+DEPEND=""
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+       mkdir build inst
+       epatch "${FILESDIR}"/${PN}-4.6.1-config.patch
+       epatch "${FILESDIR}"/${PN}-4.6.1-config-1.patch
+       epatch "${FILESDIR}"/${PN}-4.6.1-lang.patch
+       epatch "${FILESDIR}"/${PN}-4.6.1-prtime.patch
+       gnuconfig_update
+}
+
+src_compile() {
+       cd build
+
+       if use amd64 || use ppc64 || use ia64 || use s390; then
+               myconf="${myconf} --enable-64bit"
+       else
+               myconf=""
+       fi
+
+       if use ipv6; then
+               myconf="${myconf} --enable-ipv6"
+       fi
+
+       ../mozilla/nsprpub/configure \
+               --build=${CBUILD:-${CHOST}} \
+               --host=${CHOST} \
+               --prefix=/usr \
+               --libdir=/usr/$(get_libdir)/nspr \
+               --infodir=/usr/share/info \
+               --mandir=/usr/share/man \
+               $(use_enable debug) \
+               ${myconf} || die "./configure failed"
+       make || die
+}
+
+src_install () {
+       # Their build system is royally fucked, as usual
+       MINOR_VERSION=6
+       cd ${S}/build
+       make install
+       insinto /usr
+       doins -r dist/*
+       rm -rf ${D}/usr/bin/lib*.so
+
+       #removing includes/nspr/md as per fedora spec
+       # i.e a waste of space!
+       rm -rf ${D}/usr/include/nspr/md
+
+       # there have been /usr/lib/nspr changes (like the ldpath below), but never
+       # have I seen any libraries end up in this directory. lets fix that.
+       # note: I tried doing this fix via the build system. It wont work.
+       if [ ! -e ${D}/usr/lib/nspr ] ; then
+               mkdir -p ${D}/usr/lib/nspr
+               mv ${D}/usr/lib/*so* ${D}/usr/lib/nspr
+               mv ${D}/usr/lib/*\.a ${D}/usr/lib/nspr
+       fi
+       # and while we're at it, lets make it actually use the arch's libdir damnit
+       if [ "lib" != "$(get_libdir)" ] ; then
+               mv ${D}/usr/lib ${D}/usr/$(get_libdir)
+       fi
+       #and while at it move them to files with versions-ending
+       #and link them back :)
+       cd ${D}/usr/$(get_libdir)/nspr
+       for file in *.so; do
+               mv ${file} ${file}.${MINOR_VERSION}
+               ln -s ${file}.${MINOR_VERSION} ${file}
+       done
+       # cope with libraries being in /usr/lib/nspr
+       dodir /etc/env.d
+       echo "LDPATH=/usr/$(get_libdir)/nspr" > ${D}/etc/env.d/08nspr
+
+       # install nspr-config
+       insinto  /usr/bin
+       doins ${S}/build/config/nspr-config
+       chmod a+x ${D}/usr/bin/nspr-config
+
+       # create pkg-config file
+       insinto /usr/$(get_libdir)/pkgconfig/
+       doins ${S}/build/config/nspr.pc
+}
index 21504fc584861cf59218cfd2a8484a38993288dd..fb1933a3622f2320843f43b860ef7ff2eb7cd3eb 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for dev-libs/nss
 # Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.74 2006/10/06 23:08:35 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/ChangeLog,v 1.75 2006/12/21 22:14:47 alonbl Exp $
+
+*nss-3.11.4 (21 Dec 2006)
+
+  21 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org> +nss-3.11.4.ebuild:
+  Version bump, closes bug#158707, thanks to Walter Meinl
 
 *nss-3.11.3-r1 (06 Oct 2006)
 
diff --git a/dev-libs/nss/files/digest-nss-3.11.4 b/dev-libs/nss/files/digest-nss-3.11.4
new file mode 100644 (file)
index 0000000..1b12837
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 74af8ebdf94307f47ff8931adbef9c39 nss-3.11.4.tar.gz 3713920
+RMD160 5047c7f56444b22bc5f64dbaa02576e48ab5ef2a nss-3.11.4.tar.gz 3713920
+SHA256 c50062df123d733f25d4903f42e8855adf51b7324c786c714f7dd1ab9e328f06 nss-3.11.4.tar.gz 3713920
diff --git a/dev-libs/nss/nss-3.11.4.ebuild b/dev-libs/nss/nss-3.11.4.ebuild
new file mode 100644 (file)
index 0000000..aeb9b99
--- /dev/null
@@ -0,0 +1,109 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/nss/nss-3.11.4.ebuild,v 1.1 2006/12/21 22:14:47 alonbl Exp $
+
+inherit eutils flag-o-matic
+
+NSPR_VER="4.6.4"
+RTM_NAME="NSS_${PV//./_}_RTM"
+DESCRIPTION="Mozilla's Netscape Security Services Library that implements PKI support"
+HOMEPAGE="http://www.mozilla.org/projects/security/pki/nss/"
+SRC_URI="ftp://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/${RTM_NAME}/src/${P}.tar.gz"
+
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/libc
+       app-arch/zip
+       >=dev-libs/nspr-${NSPR_VER}"
+
+src_unpack() {
+       unpack ${A}
+
+       # hack nspr paths
+       echo 'INCLUDES += -I${ROOT}/usr/include/nspr -I$(DIST)/include/dbm' \
+               >> ${S}/mozilla/security/coreconf/headers.mk || die "failed to append include"
+
+       # cope with nspr being in /usr/$(get_libdir)/nspr
+       sed -e 's:$(DIST)/lib:${ROOT}/usr/'"$(get_libdir)"/nspr':' \
+               -i ${S}/mozilla/security/coreconf/location.mk
+
+       # modify install path
+       sed -e 's:SOURCE_PREFIX = $(CORE_DEPTH)/\.\./dist:SOURCE_PREFIX = $(CORE_DEPTH)/dist:' \
+               -i ${S}/mozilla/security/coreconf/source.mk
+
+       cd ${S}
+       epatch ${FILESDIR}/${PN}-3.11-config.patch
+       epatch ${FILESDIR}/${PN}-3.11-config-1.patch
+       epatch ${FILESDIR}/${PN}-mips64.patch
+}
+
+src_compile() {
+       strip-flags
+       if use amd64 || use ppc64 || use ia64 || use s390; then
+               export USE_64=1
+       fi
+       export NSDISTMODE=copy
+       cd ${S}/mozilla/security/coreconf
+       emake -j1 BUILD_OPT=1 XCFLAGS="${CFLAGS}" || die "coreconf make failed"
+       cd ${S}/mozilla/security/dbm
+       emake -j1 BUILD_OPT=1 XCFLAGS="${CFLAGS}" || die "dbm make failed"
+       cd ${S}/mozilla/security/nss
+       emake -j1 BUILD_OPT=1 XCFLAGS="${CFLAGS}" || die "nss make failed"
+}
+
+src_install () {
+       MINOR_VERSION=11
+       cd ${S}/mozilla/security/dist
+
+       # put all *.a files in /usr/lib/nss (because some have conflicting names
+       # with existing libraries)
+       dodir /usr/$(get_libdir)/nss
+       cp -L */lib/*.so ${D}/usr/$(get_libdir)/nss || die "copying shared libs failed"
+       cp -L */lib/*.chk ${D}/usr/$(get_libdir)/nss || die "copying chk files failed"
+       cp -L */lib/*.a ${D}/usr/$(get_libdir)/nss || die "copying libs failed"
+
+       # all the include files
+       insinto /usr/include/nss
+       doins private/nss/*.h
+       doins public/nss/*.h
+       cd ${D}/usr/$(get_libdir)/nss
+       for file in *.so; do
+               mv ${file} ${file}.${MINOR_VERSION}
+               ln -s ${file}.${MINOR_VERSION} ${file}
+       done
+
+       # coping with nss being in a different path. We move up priority to
+       # ensure that nss/nspr are used specifically before searching elsewhere.
+       dodir /etc/env.d
+       echo "LDPATH=/usr/$(get_libdir)/nss" > ${D}/etc/env.d/08nss
+
+       dodir /usr/bin
+       dodir /usr/$(get_libdir)/pkgconfig
+       cp ${FILESDIR}/nss-config.in ${D}/usr/bin/nss-config
+       cp ${FILESDIR}/nss.pc.in ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+       NSS_VMAJOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMAJOR" | awk '{print $3}'`
+       NSS_VMINOR=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VMINOR" | awk '{print $3}'`
+       NSS_VPATCH=`cat ${S}/mozilla/security/nss/lib/nss/nss.h | grep "#define.*NSS_VPATCH" | awk '{print $3}'`
+
+       sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+               -e "s,@prefix@,/usr,g" \
+               -e "s,@exec_prefix@,\$\{prefix},g" \
+               -e "s,@includedir@,\$\{prefix}/include/nss,g" \
+               -e "s,@MOD_MAJOR_VERSION@,$NSS_VMAJOR,g" \
+               -e "s,@MOD_MINOR_VERSION@,$NSS_VMINOR,g" \
+               -e "s,@MOD_PATCH_VERSION@,$NSS_VPATCH,g" \
+               -i ${D}/usr/bin/nss-config
+       chmod 755 ${D}/usr/bin/nss-config
+
+       sed -e "s,@libdir@,/usr/"$(get_libdir)"/nss,g" \
+             -e "s,@prefix@,/usr,g" \
+             -e "s,@exec_prefix@,\$\{prefix},g" \
+             -e "s,@includedir@,\$\{prefix}/include/nss," \
+             -e "s,@NSPR_VERSION@,`nspr-config --version`,g" \
+             -e "s,@NSS_VERSION@,$NSS_VMAJOR.$NSS_VMINOR.$NSS_VPATCH,g" \
+             -i ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+       chmod 644 ${D}/usr/$(get_libdir)/pkgconfig/nss.pc
+}