dev-python/bz2file: Bump to 0.98
authorMichał Górny <mgorny@gentoo.org>
Tue, 21 Nov 2017 21:20:50 +0000 (22:20 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 21 Nov 2017 22:26:40 +0000 (23:26 +0100)
dev-python/bz2file/Manifest [new file with mode: 0644]
dev-python/bz2file/bz2file-0.98.ebuild [new file with mode: 0644]
dev-python/bz2file/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/bz2file/Manifest b/dev-python/bz2file/Manifest
new file mode 100644 (file)
index 0000000..f8c6f14
--- /dev/null
@@ -0,0 +1 @@
+DIST bz2file-0.98.tar.gz 11333 BLAKE2B 4ec4687f609521a637c20a512b544cd99d7c334f7cffaeff71d2a893eefe131a10bd548b9f1e829c899cdcf181f5e877e092cf08d709bb3f1ba9901d3386b3e6 SHA512 2d28e71fe71b5fea4008d65a1fa91d5c6fafcacc09f891c5deaaa985661576bd97f2e33fe9f8c5943841f09c153f2079a2511329c066e57c775fb0b089b30b20
diff --git a/dev-python/bz2file/bz2file-0.98.ebuild b/dev-python/bz2file/bz2file-0.98.ebuild
new file mode 100644 (file)
index 0000000..7fcf930
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+inherit distutils-r1
+
+DESCRIPTION="Replacement for bz2.BZ2File with features from newest CPython"
+HOMEPAGE="https://pypi.python.org/pypi/bz2file https://github.com/nvawda/bz2file"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+python_test() {
+       "${PYTHON}" test_bz2file.py -v || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/bz2file/metadata.xml b/dev-python/bz2file/metadata.xml
new file mode 100644 (file)
index 0000000..d465336
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">nvawda/bz2file</remote-id>
+               <remote-id type="pypi">bz2file</remote-id>
+       </upstream>
+</pkgmetadata>