sys-apps/nix: change 'etc_profile' to 'etc-profile'
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 20 Sep 2019 22:44:21 +0000 (23:44 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 20 Sep 2019 22:44:21 +0000 (23:44 +0100)
Reported-by: Michał Górny
Closes: https://bugs.gentoo.org/695114
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-apps/nix/metadata.xml
sys-apps/nix/nix-2.2.2.ebuild
sys-apps/nix/nix-2.3.ebuild

index c7035d7472ffe72a529cc238c580ace7eb2bc0e0..ebcafee28dab05064be6b58b1c9ec54fa5006e67 100644 (file)
@@ -6,7 +6,7 @@
                <name>Sergei Trofimovich</name>
        </maintainer>
        <use>
-               <flag name="etc_profile">Install /etc/profile.d/ entry to inject nix support for all users.</flag>
+               <flag name="etc-profile">Install /etc/profile.d/ entry to inject nix support for all users.</flag>
                <flag name="gc">Enable garbage collection in the Nix expression evaluator (use <pkg>dev-libs/boehm-gc</pkg>).</flag>
                <flag name="s3">Enable Amazon S3 bucket to load and store packages (use <pkg>dev-libs/aws-sdk-cpp</pkg>).</flag>
                <flag name="sodium">Use <pkg>dev-libs/libsodium</pkg> for cryptography</flag>
index 583f372e75c27cb5febe72be482c98c730b8f558..bf8307338008dd2e2acd6bb9ce829f1ad2dfbd4d 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="http://nixos.org/releases/${PN}/${P}/${P}.tar.xz"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="+etc_profile +gc doc s3 +sodium"
+IUSE="+etc-profile +gc doc s3 +sodium"
 
 # sys-apps/busybox is needed for sandbox mount of /bin/sh
 RDEPEND="
@@ -128,15 +128,15 @@ src_install() {
 
        newinitd "${FILESDIR}"/nix-daemon.initd nix-daemon
 
-       if ! use etc_profile; then
+       if ! use etc-profile; then
                rm "${ED}"/etc/profile.d/nix.sh || die
                rm "${ED}"/etc/profile.d/nix-daemon.sh || die
        fi
 }
 
 pkg_postinst() {
-       if ! use etc_profile; then
-               ewarn "${EROOT}/etc/profile.d/nix.sh was removed (due to USE=-etc_profile)."
+       if ! use etc-profile; then
+               ewarn "${EROOT}/etc/profile.d/nix.sh was removed (due to USE=-etc-profile)."
        fi
 
        readme.gentoo_print_elog
index 448e5bbc051e3cc42cdee2f7e442f3ea71e44de6..2a368774542b94492fb83bc2dff4101cf0ae1d03 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="http://nixos.org/releases/${PN}/${P}/${P}.tar.xz"
 LICENSE="LGPL-2.1"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="+etc_profile +gc doc s3 +sodium"
+IUSE="+etc-profile +gc doc s3 +sodium"
 
 # sys-apps/busybox is needed for sandbox mount of /bin/sh
 RDEPEND="
@@ -122,15 +122,15 @@ src_install() {
 
        newinitd "${FILESDIR}"/nix-daemon.initd nix-daemon
 
-       if ! use etc_profile; then
+       if ! use etc-profile; then
                rm "${ED}"/etc/profile.d/nix.sh || die
                rm "${ED}"/etc/profile.d/nix-daemon.sh || die
        fi
 }
 
 pkg_postinst() {
-       if ! use etc_profile; then
-               ewarn "${EROOT}/etc/profile.d/nix.sh was removed (due to USE=-etc_profile)."
+       if ! use etc-profile; then
+               ewarn "${EROOT}/etc/profile.d/nix.sh was removed (due to USE=-etc-profile)."
        fi
 
        readme.gentoo_print_elog