dev-lang/nim: drop old
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 12 Feb 2020 22:28:24 +0000 (22:28 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 12 Feb 2020 22:32:41 +0000 (22:32 +0000)
Package-Manager: Portage-2.3.88, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-lang/nim/Manifest
dev-lang/nim/nim-1.0.2.ebuild [deleted file]
dev-lang/nim/nim-1.0.4.ebuild [deleted file]

index cf27238f3ec04ea02281157efeac0d7030545890..fec632e8c2c6a1d6994b9f3f97a336427e59d0f9 100644 (file)
@@ -1,3 +1 @@
-DIST nim-1.0.2.tar.xz 5139712 BLAKE2B bcb0f0fa2ed6069021a6359e453def7beccb6e767e3e1111ff27d8fb2adb7351336f219a88e2450df3d4aece1dd7f6e1a8fb891aa31581c32bb2535d2cf604a7 SHA512 5d7a45efcf656d5467554c3bbf42d0c62a760ccd107cec439d8375839d2e80baadfb3f598598748ef8e1b32d3eb931caaa273f8e41bbf6f4e16c7afbef745349
-DIST nim-1.0.4.tar.xz 5161396 BLAKE2B ff6f5b51775bfc8e83cf5ed91bf70d63d6af40cb8802d765b27a306d6a1c93ecbd4de64edfe9537b659c89c62c92ab46008d55616c7143fa9b8adaa4e905aa66 SHA512 0614259372500da4e5d67822d3caeec4c9ec6b1a06494768cfaff1db960484c1e9c1aafe70b05d1ac07b5f22d8ff57214f455e95dba26a5648d2186f13d1265a
 DIST nim-1.0.6.tar.xz 5153708 BLAKE2B c3263d4cf19629093306fa93decf038d8b19b8d810b7e782f84708b6771e2950554cda7c6f3d63e8dc6d2b604649fd31bd7009e51bea49ae556aa973cefc4167 SHA512 8da5281a8d93349996cbbe445e21fa9525c56e5721578ede2ae0f668cb2f29641db7d50a1b1a3e2c404ce56cb83dca10df5cbc84983242646a735b8f58d05f80
diff --git a/dev-lang/nim/nim-1.0.2.ebuild b/dev-lang/nim/nim-1.0.2.ebuild
deleted file mode 100644 (file)
index 160171c..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 multiprocessing toolchain-funcs
-
-DESCRIPTION="compiled, garbage-collected systems programming language"
-HOMEPAGE="https://nim-lang.org/"
-SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc +readline test"
-
-RESTRICT=test # need to sort out depends and numerous failures
-
-RDEPEND="
-       readline? ( sys-libs/readline:0= )
-"
-DEPEND="
-       ${DEPEND}
-       test? ( net-libs/nodejs )
-"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.20.0-paths.patch
-)
-
-_run() {
-       echo "$@"
-       "$@" || die "'$*' failed"
-}
-
-nim_use_enable() {
-       [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
-       use $1 && echo "-d:$2"
-}
-
-src_compile() {
-       export XDG_CACHE_HOME=${T}/cache #667182
-       tc-export CC LD
-
-       _run ./build.sh
-
-       _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
-       _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
-       # build nimble and friends
-       # --stable to avoid pulling HEAD nimble
-       PATH="./bin:$PATH" _run ./koch --stable tools
-
-       if use doc; then
-               PATH="./bin:$PATH" _run ./koch doc
-       fi
-}
-
-src_test() {
-       PATH="./bin:$PATH" _run ./koch test
-}
-
-src_install() {
-       PATH="./bin:$PATH" _run ./koch install "${ED}"
-       rm -r "${ED}/usr/share/nim/doc" || die "failed to remove 'doc'"
-
-       exeinto /usr/bin
-
-       local bin_exe
-       for bin_exe in bin/*; do
-               # './koch install' installs only 'nim' binary
-               # but not the rest
-               [[ ${bin_exe} == bin/nim ]] && continue
-               doexe "${bin_exe}"
-       done
-
-       use doc && dodoc doc/html/*.html
-       newbashcomp tools/nim.bash-completion ${PN}
-}
diff --git a/dev-lang/nim/nim-1.0.4.ebuild b/dev-lang/nim/nim-1.0.4.ebuild
deleted file mode 100644 (file)
index 160171c..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit bash-completion-r1 multiprocessing toolchain-funcs
-
-DESCRIPTION="compiled, garbage-collected systems programming language"
-HOMEPAGE="https://nim-lang.org/"
-SRC_URI="https://nim-lang.org/download/${P}.tar.xz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc +readline test"
-
-RESTRICT=test # need to sort out depends and numerous failures
-
-RDEPEND="
-       readline? ( sys-libs/readline:0= )
-"
-DEPEND="
-       ${DEPEND}
-       test? ( net-libs/nodejs )
-"
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.20.0-paths.patch
-)
-
-_run() {
-       echo "$@"
-       "$@" || die "'$*' failed"
-}
-
-nim_use_enable() {
-       [[ -z $2 ]] && die "usage: nim_use_enable <USE flag> <compiler flag>"
-       use $1 && echo "-d:$2"
-}
-
-src_compile() {
-       export XDG_CACHE_HOME=${T}/cache #667182
-       tc-export CC LD
-
-       _run ./build.sh
-
-       _run ./bin/nim --parallelBuild:$(makeopts_jobs) c koch
-       _run ./koch boot --parallelBuild:$(makeopts_jobs) -d:release $(nim_use_enable readline useGnuReadline)
-       # build nimble and friends
-       # --stable to avoid pulling HEAD nimble
-       PATH="./bin:$PATH" _run ./koch --stable tools
-
-       if use doc; then
-               PATH="./bin:$PATH" _run ./koch doc
-       fi
-}
-
-src_test() {
-       PATH="./bin:$PATH" _run ./koch test
-}
-
-src_install() {
-       PATH="./bin:$PATH" _run ./koch install "${ED}"
-       rm -r "${ED}/usr/share/nim/doc" || die "failed to remove 'doc'"
-
-       exeinto /usr/bin
-
-       local bin_exe
-       for bin_exe in bin/*; do
-               # './koch install' installs only 'nim' binary
-               # but not the rest
-               [[ ${bin_exe} == bin/nim ]] && continue
-               doexe "${bin_exe}"
-       done
-
-       use doc && dodoc doc/html/*.html
-       newbashcomp tools/nim.bash-completion ${PN}
-}