dev-python/wheel: version bump to 0.30.0
authorTim Harder <radhermit@gentoo.org>
Thu, 19 Oct 2017 08:04:13 +0000 (04:04 -0400)
committerTim Harder <radhermit@gentoo.org>
Thu, 19 Oct 2017 08:19:40 +0000 (04:19 -0400)
dev-python/wheel/Manifest
dev-python/wheel/wheel-0.30.0.ebuild [new file with mode: 0644]

index 5c929bfe73160bfd603f8879be2fa6a1a592b3ab..95e163158e5fb2b5f646bdfe1c1e47ee8e94a1b5 100644 (file)
@@ -1 +1,2 @@
 DIST wheel-0.29.0.tar.gz 54143 SHA256 1ebb8ad7e26b448e9caa4773d2357849bf80ff9e313964bcaf79cbf0201a1648 SHA512 b72dec3cf71e3d87c611ff41f1381ed7f2c654edb50c808fb4fd0f552bab3572434495bf18c36d2ecc7cb8b355782054d3d6dedd5589ffda15027e72cff24602 WHIRLPOOL 93e501fc17208ece626217fda30b07991c6b7f73f16f1d7d5bf338ff0a21e4aed3c44ec243626cfda622c6e1e991ecc856a1cd6caf8e68b99e1edac46321e47e
+DIST wheel-0.30.0.tar.gz 43087 SHA256 9515fe0a94e823fd90b08d22de45d7bde57c90edce705b22f5e1ecf7e1b653c8 SHA512 d39fb683ca2937745b057464ec17f5fab0475c2b1225cc4c84f1b0e8cd61a4bb039730dafdaa687f7b054ce080c4b7acbd3196045db14e015585536fcf498f84 WHIRLPOOL afa6db195e7740bbb308184ad709b9ffc029f3622e643a6b4ce9f17c1db02ed61f3ac291bd250bd2de18f99069d7ebf4cf682b6b18d788733a68e7b0aa7cc2eb
diff --git a/dev-python/wheel/wheel-0.30.0.ebuild b/dev-python/wheel/wheel-0.30.0.ebuild
new file mode 100644 (file)
index 0000000..e0b07ec
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="A built-package format for Python"
+HOMEPAGE="https://pypi.python.org/pypi/wheel"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/jsonschema[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]"
+#      test? (
+#              dev-python/keyring
+#              dev-python/keyrings_alt
+#              dev-python/ed25519ll
+#              dev-python/pytest[${PYTHON_USEDEP}]
+#      )
+#"
+
+# Fails somehow
+RESTRICT=test
+
+python_test() {
+       sed \
+               -e 's:--cov=wheel::g' \
+               -i setup.cfg || die
+       py.test -v -v || die "testsuite failed under ${EPYTHON}"
+}
+
+pkg_postinst() {
+       optfeature "Signature support" \
+               dev-python/keyring \
+               dev-python/keyrings_alt \
+               dev-python/ed25519ll
+}