dev-python/rfc3987: bump to 1.3.8
authorAlexis Ballier <aballier@gentoo.org>
Mon, 7 Jan 2019 19:37:24 +0000 (20:37 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Mon, 7 Jan 2019 19:37:24 +0000 (20:37 +0100)
Package-Manager: Portage-2.3.54, Repoman-2.3.12
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-python/rfc3987/Manifest
dev-python/rfc3987/rfc3987-1.3.8.ebuild [new file with mode: 0644]

index 8d8731d355cc4c82570eb63b3f3d0c502d4ba57d..29a0f15d4c481a35b55d42c050e426c0fdbc3d02 100644 (file)
@@ -1 +1,2 @@
 DIST rfc3987-1.3.7.tar.gz 20701 BLAKE2B 234f3dc60d83e5615ae9fbbc14d063f9a993a532f5e7042144a8f5e995d44a27d88c284f7e12ff1f3f92d2440333438b3e1a0804ab43ca229305ce20ec4cb4f2 SHA512 c5fa8eb36358f7f42d12adc305031bfff7bd77e83316ad4458ed07acc6094c7d9109b95848b9296dcbc6677ce34aa59b1be8fd57dfcdc6be47eb92aeda51c518
+DIST rfc3987-1.3.8.tar.gz 20700 BLAKE2B 0662a5f376680a18eb58c76b5d1d4df653f62df7175f8c3f828cf8a410f900ba8feb81faf4ce40fabeecb74047e6b1542e170fba946d3189b18c553f16eda1e4 SHA512 0e81b8dbc8c410f08b1efa7ee1c90174ed6e70bf7622d3748f598d383583b439908e1b5da1e1a1eb22af4f214ae08680a29f00b253f37808034bae8a1808c32c
diff --git a/dev-python/rfc3987/rfc3987-1.3.8.ebuild b/dev-python/rfc3987/rfc3987-1.3.8.ebuild
new file mode 100644 (file)
index 0000000..7e5f142
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Parsing and validation of URIs (RFC 3986) and IRIs (RFC 3987)"
+HOMEPAGE="https://github.com/dgerber/rfc3987 https://pypi.org/project/rfc3987/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="$(python_gen_cond_dep \
+       'dev-python/regex[${PYTHON_USEDEP}]' python2_7 'python3*' pypy)"
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+python_test() {
+       ${EPYTHON} -m doctest -v "${S}/${PN}.py" || die
+}