x11-misc/xkeyboard-config: Use python-any-r1
authorBenda Xu <heroxbd@gentoo.org>
Thu, 19 Mar 2020 22:13:03 +0000 (15:13 -0700)
committerMatt Turner <mattst88@gentoo.org>
Thu, 19 Mar 2020 22:30:43 +0000 (15:30 -0700)
Closes: https://bugs.gentoo.org/712792
Signed-off-by: Benda Xu <heroxbd@gentoo.org>
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-misc/xkeyboard-config/xkeyboard-config-2.29.ebuild
x11-misc/xkeyboard-config/xkeyboard-config-9999.ebuild

index 6ff6eec8778a2f019c2d68171312e955a7127099..2bbc4b24325b2d4d6b039b2b4ab2bdb1ae5625e8 100644 (file)
@@ -3,6 +3,9 @@
 
 EAPI=7
 
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1
+
 DESCRIPTION="X keyboard configuration database"
 HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
 
@@ -32,6 +35,10 @@ PATCHES=(
        "${FILESDIR}"/${P}-fix-python3-support.patch
 )
 
+pkg_setup() {
+       python-any-r1_pkg_setup
+}
+
 src_prepare() {
        default
        [[ ${PV} == 9999 ]] && eautoreconf
index 712663d9504cb212d4ea6b15647fecc1f2e58aac..8d54fdae4de82f5b94772cc9f972fa2b5b34ee0e 100644 (file)
@@ -3,6 +3,9 @@
 
 EAPI=7
 
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit python-any-r1
+
 DESCRIPTION="X keyboard configuration database"
 HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
 
@@ -28,6 +31,10 @@ BDEPEND="
 RDEPEND=""
 DEPEND="${LIVE_DEPEND}"
 
+pkg_setup() {
+       python-any-r1_pkg_setup
+}
+
 src_prepare() {
        default
        [[ ${PV} == 9999 ]] && eautoreconf