dev-python/python-gnupg: Clean old versions up
authorMichał Górny <mgorny@gentoo.org>
Tue, 2 May 2017 18:21:09 +0000 (20:21 +0200)
committerMichał Górny <mgorny@gentoo.org>
Tue, 2 May 2017 19:15:13 +0000 (21:15 +0200)
dev-python/python-gnupg/Manifest
dev-python/python-gnupg/files/python-gnupg-0.3.7-msg-handle.patch [deleted file]
dev-python/python-gnupg/python-gnupg-0.3.7.ebuild [deleted file]
dev-python/python-gnupg/python-gnupg-0.3.8.ebuild [deleted file]

index daffb933cd69c661da6c171a3c694e517970bffb..87f7c5e9c76483cd9395b90a2a3de34db45d5fb2 100644 (file)
@@ -1,2 +1 @@
-DIST python-gnupg-0.3.7.tar.gz 48728 SHA256 2bf59ff55c036e49d5da12d370447679f14d242567df4c2c0fc61b4601ca0d59 SHA512 6166cef11307dd4782000ab7263778436998a816a45e4471fcbe244b123703bf9ded5bc6ef5cd47ed0c561ef42660980576edf57c62029bb0326642b7c538dd3 WHIRLPOOL 93770439486689dfcaf296d158c3978a71c72d32ba9f0e5b4ec4c97dfda16177ee5e06f0b616112cdfb9cd96c3a93700a0d4302116401c6146f3cd7437b7e29b
 DIST python-gnupg-0.3.8.tar.gz 38993 SHA256 3872ced77d69203f31817107b324b0dd33d4437a330dc58eca140c8758d26b5a SHA512 128ba1f89e8baf0d1ae53153d7cbe73bfc99617a1aadfd9a02e2e2e2c5f0bb9c7482023bf54f32989e92cc14a9eb32325e4c358c63bce48a70a78d068103ed4f WHIRLPOOL 9080ceeade7e4c614a532eccbd4e9818d62233a6d1751acb159e8e0f13c71edf177d2c1592f0685c7e4139ba59826b8cb13864c11c37e33445a176c693d84f52
diff --git a/dev-python/python-gnupg/files/python-gnupg-0.3.7-msg-handle.patch b/dev-python/python-gnupg/files/python-gnupg-0.3.7-msg-handle.patch
deleted file mode 100644 (file)
index 9f4b6f5..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-https://bitbucket.org/vinay.sajip/python-gnupg/commits/79c73a9ce6e33555246f9dae2ef4be9964e2704b
-# HG changeset patch
-# User Vinay Sajip <vinay_sajip@yahoo.co.uk>
-# Date 1419023737 0
-# Node ID 79c73a9ce6e33555246f9dae2ef4be9964e2704b
-# Parent  767aa49b175738b6d0404a2fb2fca3e3c081e0a8
-Closes #22: handled PROGRESS messages during verification and signing.
-
-diff --git a/gnupg.py b/gnupg.py
---- a/gnupg.py
-+++ b/gnupg.py
-@@ -221,7 +221,8 @@
-                      "PLAINTEXT_LENGTH", "POLICY_URL", "DECRYPTION_INFO",
-                      "DECRYPTION_OKAY", "INV_SGNR", "FILE_START", "FILE_ERROR",
-                      "FILE_DONE", "PKA_TRUST_GOOD", "PKA_TRUST_BAD", "BADMDC",
--                     "GOODMDC", "NO_SGNR", "NOTATION_NAME", "NOTATION_DATA"):
-+                     "GOODMDC", "NO_SGNR", "NOTATION_NAME", "NOTATION_DATA",
-+                     "PROGRESS"):
-             pass
-         elif key == "BADSIG":
-             self.valid = False
-@@ -601,7 +602,7 @@
-         if key in ("USERID_HINT", "NEED_PASSPHRASE", "BAD_PASSPHRASE",
-                    "GOOD_PASSPHRASE", "BEGIN_SIGNING", "CARDCTRL", "INV_SGNR",
-                    "NO_SGNR", "MISSING_PASSPHRASE", "NEED_PASSPHRASE_PIN",
--                   "SC_OP_FAILURE", "SC_OP_SUCCESS"):
-+                   "SC_OP_FAILURE", "SC_OP_SUCCESS", "PROGRESS"):
-             pass
-         elif key in ("KEYEXPIRED", "SIGEXPIRED"):
-             self.status = 'key expired'
-
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.7.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.7.ebuild
deleted file mode 100644 (file)
index c654ae4..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for GNU Privacy Guard"
-HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
-SRC_URI="https://github.com/vsajip/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="app-crypt/gnupg"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch
-               "${FILESDIR}"/${P}-msg-handle.patch )
-
-python_test() {
-       # Note; 1 test fails under pypy only
-       "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
-}
diff --git a/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild b/dev-python/python-gnupg/python-gnupg-0.3.8.ebuild
deleted file mode 100644 (file)
index f75c75e..0000000
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} pypy )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for GNU Privacy Guard"
-HOMEPAGE="http://pythonhosted.org/python-gnupg/ https://github.com/vsajip/python-gnupg/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="app-crypt/gnupg"
-DEPEND="${RDEPEND}"
-
-PATCHES=( "${FILESDIR}"/${PN}-0.3.6-skip-search-keys-tests.patch )
-
-python_test() {
-       # Note; 1 test fails under pypy only
-       "${PYTHON}" test_gnupg.py || die "Tests fail with ${EPYTHON}"
-}