dev-python/json-rpc: clean up old.
authorPatrice Clement <monsieurp@gentoo.org>
Thu, 23 Aug 2018 18:48:20 +0000 (20:48 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 23 Aug 2018 18:50:37 +0000 (20:50 +0200)
Closes: https://bugs.gentoo.org/620110

Make sure to use version 1.11.0 in order to get working suite of tests.

Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/json-rpc/Manifest
dev-python/json-rpc/json-rpc-1.10.1.ebuild [deleted file]

index 93316d2f9fc53c76d405c9e990c125b9b38cf8ec..6c1ad4fc9aa052c78ec3983c0d4b9c945be77e19 100644 (file)
@@ -1,2 +1 @@
-DIST json-rpc-1.10.1.tar.gz 25410 BLAKE2B bb543dc9987d7aa4880d1981fad888ae9374f51958a2b7934e2779fc835705c03946cb3378ca60a914a130ae78741cda75da40ee8ce76e6b4af17a2e98498089 SHA512 bb69cbb12c0a64286fb1e98db21ca75cb19daf20c6d6f5721f82891a17e44d2cda172e73bd389a02077d094b8f6deb0959952b0498b0c1b4a0acfaa5e3ba3922
 DIST json-rpc-1.11.0.tar.gz 29442 BLAKE2B b2a77bdcc2f5efe64527feb29b28c0add90b9fdbd5aa73dce18c33e9a10342c1e6b04ed5d53c110e3f1b6287cf1fdca9db77e38a04651e0a522b76c0351ec993 SHA512 aa5a467ef0e6e556612f77855d38f0dfb76b22556490fac5f0989d27b7608aed8389042ded1a0d8fcbee1f20294c78a6af3c030f41c4e30ec1effae8e51530fb
diff --git a/dev-python/json-rpc/json-rpc-1.10.1.ebuild b/dev-python/json-rpc/json-rpc-1.10.1.ebuild
deleted file mode 100644 (file)
index 8577529..0000000
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="JSON-RPC transport implementation for python"
-HOMEPAGE="https://github.com/pavlov99/json-rpc"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64"
-IUSE="test"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/nose[${PYTHON_USEDEP}]
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/flask[${PYTHON_USEDEP}]
-       )"
-
-python_prepare_all() {
-       cat > jsonrpc/six.py <<- EOF
-       from __future__ import absolute_import
-       from six import *
-       EOF
-       distutils-r1_python_prepare_all
-}
-
-python_test() {
-       esetup.py test
-}