sys-libs/libavc1394: EAPI-7 bump, autotools-multilib--
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 1 Jan 2020 12:23:48 +0000 (13:23 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 1 Jan 2020 13:03:12 +0000 (14:03 +0100)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
sys-libs/libavc1394/libavc1394-0.5.4-r2.ebuild [new file with mode: 0644]

diff --git a/sys-libs/libavc1394/libavc1394-0.5.4-r2.ebuild b/sys-libs/libavc1394/libavc1394-0.5.4-r2.ebuild
new file mode 100644 (file)
index 0000000..402a774
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Library for the 1394 AV/C (Audio/Video Control) Digital Interface Command Set"
+HOMEPAGE="https://sourceforge.net/projects/libavc1394/"
+SRC_URI="mirror://sourceforge/libavc1394/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+BDEPEND="virtual/pkgconfig[${MULTILIB_USEDEP}]"
+DEPEND=">=sys-libs/libraw1394-2.1.0-r1[${MULTILIB_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf --disable-static
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       find "${D}" -name '*.la' -type f -delete || die
+}