app-metrics/collectd: add procevent plugin
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 13:40:27 +0000 (15:40 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 30 Apr 2020 14:10:20 +0000 (16:10 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
app-metrics/collectd/collectd-5.11.0.ebuild
profiles/desc/collectd_plugins.desc

index f1c40831c22978034e78bf97bba648733c622fc3..0a813ac1865692772c073a87f29b306d335a3b91 100644 (file)
@@ -58,11 +58,11 @@ COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
        memcachec memcached memory modbus mqtt multimeter mysql netlink
        network network nfs nginx notify_desktop notify_email notify_nagios
        ntpd numa nut olsrd onewire openldap openvpn oracle ovs_events
-       ovs_stats perl ping postgresql powerdns processes protocols python
-       python redis routeros rrdcached rrdtool sensors serial sigrok slurm
-       smart snmp snmp_agent statsd swap sysevent syslog table tail tail_csv
-       target_notification target_replace target_scale target_set tcpconns
-       teamspeak2 ted thermal threshold turbostat ubi unixsock
+       ovs_stats perl ping postgresql powerdns procevent processes protocols
+       python python redis routeros rrdcached rrdtool sensors serial sigrok
+       slurm smart snmp snmp_agent statsd swap sysevent syslog table tail
+       tail_csv target_notification target_replace target_scale target_set
+       tcpconns teamspeak2 ted thermal threshold turbostat ubi unixsock
        uptime users uuid varnish virt vmem vserver wireless write_graphite
        write_http write_influxdb_udp write_kafka write_log write_mongodb
        write_prometheus write_redis write_sensu write_syslog write_tsdb
@@ -119,6 +119,7 @@ COMMON_DEPEND="
        collectd_plugins_perl?                  ( dev-lang/perl:=[ithreads] )
        collectd_plugins_ping?                  ( net-libs/liboping )
        collectd_plugins_postgresql?            ( dev-db/postgresql:= )
+       collectd_plugins_procevent?             ( dev-libs/yajl:= )
        collectd_plugins_python?                ( ${PYTHON_DEPS} )
        collectd_plugins_redis?                 ( dev-libs/hiredis:= )
        collectd_plugins_routeros?              ( net-libs/librouteros )
index c5e26e3d3b419a83be3a09251c3cd7284b9982a2..804b186851c23d6b2e1d1dd76dfdf3523ed64511 100644 (file)
@@ -91,6 +91,7 @@ perl - Build the perl language binding plugin (embeds a Perl interpreter into co
 ping - Build the ping input plugin (measures network latency)
 postgresql - Build the postgresql input plugin (executes SQL statements against a PostgreSQL database)
 powerdns - Build the powerdns input plugin (collects statistics from the PowerDNS name server or recursor via control socket)
+procevent - Build the procevent input plugin (monitors process starts/stops via netlink library)
 processes - Build the processes input plugin (collects the number of processes, grouped by their state or detailed statistics about selected processes)
 protocols - Build the protocols input plugin (collects information about the network protocols supported by the system)
 python - Build the python language binding plugin (embeds a Python interpreter into collectd for writing plugins)