Added /etc/profile.d/ file for c shells. Fixes bug #159736. Thanks to Troy Bowman...
authorPetteri Räty <betelgeuse@gentoo.org>
Fri, 12 Jan 2007 17:57:48 +0000 (17:57 +0000)
committerPetteri Räty <betelgeuse@gentoo.org>
Fri, 12 Jan 2007 17:57:48 +0000 (17:57 +0000)
Package-Manager: portage-2.1.2_rc4-r7

dev-java/java-config/ChangeLog
dev-java/java-config/files/digest-java-config-2.0.31-r1 [new file with mode: 0644]
dev-java/java-config/files/java-config-2.profiled.csh [new file with mode: 0644]
dev-java/java-config/files/java-config-2.profiled.sh [new file with mode: 0644]
dev-java/java-config/java-config-2.0.31-r1.ebuild [new file with mode: 0644]

index 7844c0c2fdc8f3a5c0bb81a3cb1c186002af4d9d..4bc89aff798c7396e30ddc04022c1826d46819e0 100644 (file)
@@ -1,6 +1,14 @@
 # ChangeLog for dev-java/java-config
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.133 2006/12/17 17:35:27 betelgeuse Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/ChangeLog,v 1.134 2007/01/12 17:57:48 betelgeuse Exp $
+
+*java-config-2.0.31-r1 (12 Jan 2007)
+
+  12 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+  -files/java-config-2.profiled, +files/java-config-2.profiled.csh,
+  +files/java-config-2.profiled.sh, +java-config-2.0.31-r1.ebuild:
+  Added /etc/profile.d/ file for c shells. Fixes bug #159736. Thanks to Troy
+  Bowman <troy@dublan.net>.
 
 *java-config-2.0.31 (17 Dec 2006)
 
diff --git a/dev-java/java-config/files/digest-java-config-2.0.31-r1 b/dev-java/java-config/files/digest-java-config-2.0.31-r1
new file mode 100644 (file)
index 0000000..393d9db
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 36b7893b20b9f4b6f0af6dd632703745 java-config-2.0.31.tar.bz2 17001
+RMD160 4b3d8362538b435a642312ee7289824d6662e309 java-config-2.0.31.tar.bz2 17001
+SHA256 314ec1783da8190d60e757aaef2af8eae7281c3c9754024e3e59643ce7a30752 java-config-2.0.31.tar.bz2 17001
diff --git a/dev-java/java-config/files/java-config-2.profiled.csh b/dev-java/java-config/files/java-config-2.profiled.csh
new file mode 100644 (file)
index 0000000..ee9b65f
--- /dev/null
@@ -0,0 +1,19 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/files/java-config-2.profiled.csh,v 1.1 2007/01/12 17:57:48 betelgeuse Exp $
+
+set gentoo_user_vm="${HOME}/.gentoo/java-config-2/current-user-vm"
+set gentoo_system_vm="/etc/java-config-2/current-system-vm"
+
+## If we have a current-user-vm (and aren't root)... set it to JAVA_HOME
+## Otherwise set to the current system vm
+if (($uid != "0") && (-l $gentoo_user_vm)) then
+    setenv JAVA_HOME $gentoo_user_vm
+else if (-L $gentoo_system_vm) then
+    setenv JAVA_HOME $gentoo_system_vm
+endif
+
+setenv JDK_HOME $JAVA_HOME
+setenv JAVAC ${JDK_HOME}/bin/javac
+unset gentoo_user_vm gentoo_system_vm
+
diff --git a/dev-java/java-config/files/java-config-2.profiled.sh b/dev-java/java-config/files/java-config-2.profiled.sh
new file mode 100644 (file)
index 0000000..8f317fa
--- /dev/null
@@ -0,0 +1,17 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/files/java-config-2.profiled.sh,v 1.1 2007/01/12 17:57:48 betelgeuse Exp $
+
+# If we have a current-user-vm (and aren't root)... set it to JAVA_HOME
+gentoo_user_vm="${HOME}/.gentoo/java-config-2/current-user-vm"
+gentoo_system_vm="/etc/java-config-2/current-system-vm"
+
+if [[ ${UID} != 0 && -L ${gentoo_user_vm} ]]; then
+       export JAVA_HOME=${gentoo_user_vm}
+# Otherwise set to the current system vm
+elif [[ -L /etc/java-config-2/current-system-vm ]]; then
+       export JAVA_HOME=${gentoo_system_vm}
+fi
+export JDK_HOME=${JAVA_HOME}
+export JAVAC=${JDK_HOME}/bin/javac
+unset gentoo_user_vm gentoo_system_vm
diff --git a/dev-java/java-config/java-config-2.0.31-r1.ebuild b/dev-java/java-config/java-config-2.0.31-r1.ebuild
new file mode 100644 (file)
index 0000000..5802cbb
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/java-config/java-config-2.0.31-r1.ebuild,v 1.1 2007/01/12 17:57:48 betelgeuse Exp $
+
+inherit base distutils eutils
+
+DESCRIPTION="Java environment configuration tool"
+HOMEPAGE="http://www.gentoo.org/proj/en/java/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-lang/python"
+RDEPEND="${DEPEND}
+       dev-java/java-config-wrapper"
+
+src_install() {
+       distutils_src_install
+
+       insinto /usr/share/java-config-2/config/
+       for i in alpha amd64 hppa ia64 ppc ppc64 sparc x86 x86-fbsd; do
+               if use ${i}; then
+                       newins config/jdk-defaults-${i}.conf jdk-defaults.conf || die "arch     config not found"
+               fi
+       done
+
+       for tool in $(< config/symlink-tools); do
+               dosym /usr/bin/run-java-tool /usr/bin/${tool}
+       done
+
+       # Install profile.d for setting JAVA_HOME
+       dodir /etc/profile.d
+       exeinto /etc/profile.d
+       newexe ${FILESDIR}/${PN}-${SLOT}.profiled.sh ${PN}-${SLOT}.sh || die "newexe failed"
+       newexe ${FILESDIR}/${PN}-${SLOT}.profiled.csh ${PN}-${SLOT}.csh || die "newexe failed"
+}
+
+
+pkg_postrm() {
+       python_mod_cleanup /usr/share/java-config-2/pym/java_config
+}
+
+pkg_postinst() {
+       python_mod_optimize /usr/share/java-config-2/pym/java_config
+
+       elog "The way Java is handled on Gentoo has been recently updated."
+       elog "If you have not done so already, you should follow the"
+       elog "instructions available at:"
+       elog "\thttp://www.gentoo.org/proj/en/java/java-upgrade.xml"
+       elog
+       elog "While we are moving towards the new Java system, we only allow"
+       elog "1.3 or 1.4 JDKs to be used with java-config-1 to ensure"
+       elog "backwards compatibility with the old system."
+       elog "For more details about this, please see:"
+       elog "\thttps://overlays.gentoo.org/proj/java/wiki/Why_We_Need_Java14"
+}