gnome-base/gnome-extra-apps: version bump to 3.18.0
authorGilles Dartiguelongue <eva@gentoo.org>
Sun, 6 Dec 2015 23:37:03 +0000 (00:37 +0100)
committerGilles Dartiguelongue <eva@gentoo.org>
Sun, 6 Dec 2015 23:40:58 +0000 (00:40 +0100)
Package-Manager: portage-2.2.26

gnome-base/gnome-extra-apps/gnome-extra-apps-3.18.0.ebuild [new file with mode: 0644]

diff --git a/gnome-base/gnome-extra-apps/gnome-extra-apps-3.18.0.ebuild b/gnome-base/gnome-extra-apps/gnome-extra-apps-3.18.0.ebuild
new file mode 100644 (file)
index 0000000..5aea7dc
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="Sub-meta package for the applications of GNOME 3"
+HOMEPAGE="https://www.gnome.org/"
+LICENSE="metapackage"
+SLOT="3.0"
+IUSE="+games +share +shotwell +tracker"
+
+# when unmasking for an arch
+# double check none of the deps are still masked !
+KEYWORDS="~amd64 ~x86"
+
+# Note to developers:
+# This is a wrapper for the extra apps integrated with GNOME 3
+# New package
+RDEPEND="
+       >=gnome-base/gnome-core-libs-${PV}
+
+       >=app-admin/gnome-system-log-3.9.90
+       >=app-arch/file-roller-3.16.4
+       >=app-dicts/gnome-dictionary-${PV}
+       >=gnome-base/dconf-editor-${PV}
+       >=gnome-extra/gconf-editor-3
+       >=gnome-extra/gnome-calculator-${PV}
+       >=gnome-extra/gnome-power-manager-${PV}
+       >=gnome-extra/gnome-search-tool-3.6
+       >=gnome-extra/gnome-system-monitor-${PV}
+       >=gnome-extra/gnome-tweak-tool-${PV}
+       >=gnome-extra/gnome-weather-${PV}
+       >=gnome-extra/gucharmap-${PV}:2.90
+       >=gnome-extra/nautilus-sendto-3.8.2
+       >=gnome-extra/sushi-${PV}
+       >=mail-client/evolution-${PV}
+       >=media-gfx/gnome-font-viewer-3.16.2
+       >=media-gfx/gnome-screenshot-${PV}
+       >=media-sound/sound-juicer-${PV}
+       >=media-video/cheese-${PV}
+       >=net-analyzer/gnome-nettool-3.8
+       >=net-misc/vinagre-${PV}
+       >=net-misc/vino-${PV}
+       >=sys-apps/baobab-${PV}
+       >=sys-apps/gnome-disk-utility-${PV}
+       >=www-client/epiphany-${PV}
+
+       games? (
+               >=games-arcade/gnome-nibbles-${PV}
+               >=games-arcade/gnome-robots-${PV}
+               >=games-board/four-in-a-row-${PV}
+               >=games-board/gnome-chess-${PV}
+               >=games-board/gnome-mahjongg-${PV}
+               >=games-board/gnome-mines-${PV}
+               >=games-board/iagno-${PV}
+               >=games-board/tali-${PV}
+               >=games-puzzle/five-or-more-${PV}
+               >=games-puzzle/gnome-klotski-${PV}
+               >=games-puzzle/gnome-sudoku-${PV}
+               >=games-puzzle/gnome-taquin-${PV}
+               >=games-puzzle/gnome-tetravex-${PV}
+               >=games-puzzle/hitori-3.16.2
+               >=games-puzzle/lightsoff-${PV}
+               >=games-puzzle/quadrapassel-${PV}
+               >=games-puzzle/swell-foop-${PV} )
+       share? ( >=gnome-extra/gnome-user-share-${PV} )
+       shotwell? ( >=media-gfx/shotwell-0.22 )
+       tracker? (
+               >=app-misc/tracker-1.6
+               >=gnome-extra/gnome-documents-${PV}
+               >=media-gfx/gnome-photos-${PV}
+               >=media-sound/gnome-music-${PV} )
+"
+DEPEND=""
+S=${WORKDIR}