dev-python/qscintilla-python: support building against Qt5/PyQt5
authorDavide Pesavento <pesa@gentoo.org>
Sat, 21 Jan 2017 22:07:04 +0000 (23:07 +0100)
committerDavide Pesavento <pesa@gentoo.org>
Sat, 21 Jan 2017 22:07:36 +0000 (23:07 +0100)
Gentoo-Bug: 541604

Package-Manager: Portage-2.3.3, Repoman-2.3.1

19 files changed:
dev-python/qscintilla-python/qscintilla-python-2.9.2-r1.ebuild
dev-python/qscintilla-python/qscintilla-python-2.9.4-r1.ebuild [new file with mode: 0644]
dev-python/qscintilla-python/qscintilla-python-2.9.4.ebuild
dev-util/eric/eric-16.12.ebuild
dev-util/eric/eric-17.01.ebuild
dev-vcs/hgview/hgview-1.9.0.ebuild
dev-vcs/tortoisehg/tortoisehg-3.8.4.ebuild
dev-vcs/tortoisehg/tortoisehg-3.9.2.ebuild
dev-vcs/tortoisehg/tortoisehg-4.0.1.ebuild
dev-vcs/tortoisehg/tortoisehg-4.0.ebuild
dev-vcs/tortoisehg/tortoisehg-9999.ebuild
net-analyzer/linkchecker/linkchecker-9.3-r1.ebuild
net-analyzer/linkchecker/linkchecker-9.3-r2.ebuild
net-analyzer/linkchecker/linkchecker-9999.ebuild
sci-geosciences/qgis/qgis-2.14.5-r1.ebuild
sci-geosciences/qgis/qgis-2.18.2-r1.ebuild
sci-geosciences/qgis/qgis-2.18.2-r2.ebuild
sci-geosciences/qgis/qgis-2.18.2-r3.ebuild
sci-geosciences/qgis/qgis-2.18.3.ebuild

index b1671d7ae8cedbb26c574b0179e956c1ecf24c4c..02e93095fa1efe971e3337ce2e393f88f23e7ed4 100644 (file)
@@ -53,7 +53,7 @@ src_configure() {
                "${myconf[@]}" || die
 
                # Run eqmake4 to respect toolchain, build flags, and prevent stripping
-               eqmake4
+               eqmake4 -recursive
        }
        python_foreach_impl run_in_build_dir configuration
 }
diff --git a/dev-python/qscintilla-python/qscintilla-python-2.9.4-r1.ebuild b/dev-python/qscintilla-python/qscintilla-python-2.9.4-r1.ebuild
new file mode 100644 (file)
index 0000000..8c66719
--- /dev/null
@@ -0,0 +1,85 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit python-r1 qmake-utils
+
+MY_P=QScintilla_gpl-${PV}
+
+DESCRIPTION="Python bindings for Qscintilla"
+HOMEPAGE="http://www.riverbankcomputing.com/software/qscintilla/intro"
+SRC_URI="mirror://sourceforge/pyqt/${MY_P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="debug +qt4 qt5"
+
+REQUIRED_USE="
+       ${PYTHON_REQUIRED_USE}
+       ^^ ( qt4 qt5 )
+"
+
+DEPEND="
+       ${PYTHON_DEPS}
+       >=dev-python/sip-4.19:=[${PYTHON_USEDEP}]
+       ~x11-libs/qscintilla-${PV}:=[qt4(-)?,qt5(+)?]
+       qt4? (
+               >=dev-python/PyQt4-4.11.3[X,${PYTHON_USEDEP}]
+               dev-qt/qtcore:4
+               dev-qt/qtgui:4
+       )
+       qt5? (
+               dev-python/PyQt5[gui,printsupport,widgets,${PYTHON_USEDEP}]
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5
+               dev-qt/qtprintsupport:5
+               dev-qt/qtwidgets:5
+       )
+"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}/Python
+
+src_prepare() {
+       default
+       python_copy_sources
+}
+
+src_configure() {
+       local my_qt_ver=$(usex qt5 5 4)
+
+       configuration() {
+               local myconf=(
+                       "${PYTHON}"
+                       configure.py
+                       --qmake="$(qt${my_qt_ver}_get_bindir)"/qmake
+                       --destdir="$(python_get_sitedir)"/PyQt${my_qt_ver}
+                       --sip-incdir="$(python_get_includedir)"
+                       --pyqt=PyQt${my_qt_ver}
+                       $(usex debug '--debug --trace' '')
+                       --verbose
+               )
+               echo "${myconf[@]}"
+               "${myconf[@]}" || die
+
+               # Run eqmake to respect toolchain, build flags, and prevent stripping
+               eqmake${my_qt_ver} -recursive
+       }
+       python_foreach_impl run_in_build_dir configuration
+}
+
+src_compile() {
+       python_foreach_impl run_in_build_dir default
+}
+
+src_install() {
+       installation() {
+               emake INSTALL_ROOT="${D}" install
+               python_optimize
+       }
+       python_foreach_impl run_in_build_dir installation
+}
index 444c5883c0da13a0db4de93c1d7aa62a65e3371c..6174d4c0a67be1763c65e46ceae0ab9e7ed29bf1 100644 (file)
@@ -53,7 +53,7 @@ src_configure() {
                "${myconf[@]}" || die
 
                # Run eqmake4 to respect toolchain, build flags, and prevent stripping
-               eqmake4
+               eqmake4 -recursive
        }
        python_foreach_impl run_in_build_dir configuration
 }
index 691a9c118ee702f330840d1b9ee8731c26a4d091..ca9846fcc02027f4191258e6828b27ec2d41e693 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -23,7 +23,7 @@ DEPEND="
        ${PYTHON_DEPS}
        >=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
        >=dev-python/PyQt4-4.10[${PYTHON_USEDEP},X,help,sql,svg,webkit]
-       >=dev-python/qscintilla-python-2.8[${PYTHON_USEDEP}]
+       >=dev-python/qscintilla-python-2.8[qt4(+),${PYTHON_USEDEP}]
 "
 RDEPEND="${DEPEND}
        >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
index eb2727e65c902e3853a17507633ba82c0cc725bb..ca9846fcc02027f4191258e6828b27ec2d41e693 100644 (file)
@@ -23,7 +23,7 @@ DEPEND="
        ${PYTHON_DEPS}
        >=dev-python/sip-4.14.3[${PYTHON_USEDEP}]
        >=dev-python/PyQt4-4.10[${PYTHON_USEDEP},X,help,sql,svg,webkit]
-       >=dev-python/qscintilla-python-2.8[${PYTHON_USEDEP}]
+       >=dev-python/qscintilla-python-2.8[qt4(+),${PYTHON_USEDEP}]
 "
 RDEPEND="${DEPEND}
        >=dev-python/chardet-2.3.0[${PYTHON_USEDEP}]
index 7f380288c942edc7e894eecc36aaa168d6f05ce0..f1c9417d45fff1c2f1c82bb27f8b5d642ad819e6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -26,7 +26,7 @@ RDEPEND="dev-vcs/mercurial[${PYTHON_USEDEP}]
        qt4? (
                dev-python/docutils[${PYTHON_USEDEP}]
                dev-python/PyQt4[X,${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
        )"
 DEPEND="${RDEPEND}
        doc? (
index add524291eededc2db9cef878a646705fbf9d4e2..0d40ccc454a98f2744bc8345f84e0ba4450ad713 100644 (file)
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
        dev-python/iniparse[${PYTHON_USEDEP}]
        dev-python/pygments[${PYTHON_USEDEP}]
        dev-python/PyQt4[svg,${PYTHON_USEDEP}]
-       dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+       dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-1.0.3 )"
 
index d6b86c8f9a8120c9c1688bcb128eba1c37cc0b57..51aa692c7b6d8d9068b8ff7a70b70b419a08affe 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
        dev-python/iniparse[${PYTHON_USEDEP}]
        dev-python/pygments[${PYTHON_USEDEP}]
        dev-python/PyQt4[svg,${PYTHON_USEDEP}]
-       dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+       dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-1.0.3 )"
 
index ae3a7bde3b80ad39e99a1a3ad6c7224189972f93..fbb9a0eb51e24d0603f11649e249e6200eb46810 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
        dev-python/iniparse[${PYTHON_USEDEP}]
        dev-python/pygments[${PYTHON_USEDEP}]
        dev-python/PyQt4[svg,${PYTHON_USEDEP}]
-       dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+       dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-1.0.3 )"
 
index ae3a7bde3b80ad39e99a1a3ad6c7224189972f93..fbb9a0eb51e24d0603f11649e249e6200eb46810 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
        dev-python/iniparse[${PYTHON_USEDEP}]
        dev-python/pygments[${PYTHON_USEDEP}]
        dev-python/PyQt4[svg,${PYTHON_USEDEP}]
-       dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+       dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-1.0.3 )"
 
index 3b0a0c0fca0cfa85efca4d92794dbb1053deaa97..9225a6dbffa4f667416fa4f87b7244156ad6691b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -31,7 +31,7 @@ RDEPEND="${HG_DEPEND}
        dev-python/iniparse[${PYTHON_USEDEP}]
        dev-python/pygments[${PYTHON_USEDEP}]
        dev-python/PyQt4[svg,${PYTHON_USEDEP}]
-       dev-python/qscintilla-python[${PYTHON_USEDEP}]"
+       dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
        doc? ( >=dev-python/sphinx-1.0.3 )"
 
index ecd8b4e399ab16ece69c9317e6b13f55238028cb..5a4f929df0fb843c7b1270f0a49585837577d7d8 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -27,7 +27,7 @@ RDEPEND="
        gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
        X? (
                dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                )"
 DEPEND="
        X? (
index c6022519ee2d3627c9a7a0751606a6653adaa799..16e55e2ff5f9e1b1e6e8e1a27aaed59062d4a272 100644 (file)
@@ -27,7 +27,7 @@ RDEPEND="
        gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
        X? (
                dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                )"
 DEPEND="
        X? (
index 01653b19b9428147221e2059b7b2114ee280bea0..ad27a47b546a215a83c6cfd124f465e27ed1d2c3 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -26,7 +26,7 @@ RDEPEND="
        gnome? ( dev-python/pygtk:2[${PYTHON_USEDEP}] )
        X? (
                dev-python/PyQt4[X,help,${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                )"
 DEPEND="
        X? (
index 3416afd9cc5e753a602cfb1768ba60a613e2f3e5..f4fa4774431ae8f22d7784456cc8d08dbbf266ef 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -51,7 +51,7 @@ RDEPEND="
        python? (
                dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
                dev-python/sip[${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                dev-python/python-dateutil[${PYTHON_USEDEP}]
                dev-python/httplib2[${PYTHON_USEDEP}]
                dev-python/jinja[${PYTHON_USEDEP}]
index dec2e4df2e0f416b12a7cb0e1638ad92a9de9228..9e687a8dcd27e1d4e841e179578d352770ddd5c5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -52,7 +52,7 @@ RDEPEND="
        python? (
                dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
                dev-python/sip[${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                dev-python/python-dateutil[${PYTHON_USEDEP}]
                dev-python/httplib2[${PYTHON_USEDEP}]
                dev-python/jinja[${PYTHON_USEDEP}]
index 2dddf93f3f5eb4b2755031ed1693b1231c60f954..7dc1b69a3e253661a5c68de304aaeaee5fea7810 100644 (file)
@@ -52,7 +52,7 @@ RDEPEND="
        python? (
                dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
                <dev-python/sip-4.19:=[${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                dev-python/python-dateutil[${PYTHON_USEDEP}]
                dev-python/httplib2[${PYTHON_USEDEP}]
                dev-python/jinja[${PYTHON_USEDEP}]
index 084b5553bba814fc65c2d7119e8ac5455bd57ee9..96193db8c9ddc91ce812d89f7daf2b816627307a 100644 (file)
@@ -53,7 +53,7 @@ RDEPEND="
        python? (
                dev-python/PyQt4[X,sql,svg,webkit,${PYTHON_USEDEP}]
                <dev-python/sip-4.19:=[${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                dev-python/python-dateutil[${PYTHON_USEDEP}]
                dev-python/httplib2[${PYTHON_USEDEP}]
                dev-python/jinja[${PYTHON_USEDEP}]
index b631f4b20f11560386876d23c924a9b71ed2c8ec..6afa49f4292c9fd091dc240c453d1b65a5244336 100644 (file)
@@ -61,7 +61,7 @@ COMMON_DEPEND="
                dev-python/python-dateutil[${PYTHON_USEDEP}]
                dev-python/pytz[${PYTHON_USEDEP}]
                dev-python/pyyaml[${PYTHON_USEDEP}]
-               dev-python/qscintilla-python[${PYTHON_USEDEP}]
+               dev-python/qscintilla-python[qt4(+),${PYTHON_USEDEP}]
                dev-python/requests[${PYTHON_USEDEP}]
                <dev-python/sip-4.19:=[${PYTHON_USEDEP}]
                dev-python/six[${PYTHON_USEDEP}]