app-portage/gentoolkit: Bump to 0.4.7
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 15:24:40 +0000 (16:24 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Jan 2020 15:24:40 +0000 (16:24 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
app-portage/gentoolkit/Manifest
app-portage/gentoolkit/gentoolkit-0.4.7.ebuild [new file with mode: 0644]

index 472aa5efdcca56b6968a0768c7a5cb781d4b3759..85682a50421f777229643f0656e6dd602c9d5e2b 100644 (file)
@@ -1 +1,2 @@
 DIST gentoolkit-0.4.6.tar.gz 3205641 BLAKE2B 7da91a313c8a9263eb7b4abd6207ece9dd602a5069a87f1e78ada13fc9f396e1f2afddaf0637c473445034cf57b5ca7631e209361a88fa3892d302b20f4cc986 SHA512 3aa3c9af7e994313400607943b9090fd813227ddd6d550b50fbcf7eeb4053da8bcdb41c9ef2579d957d2f279fdcc4e2f2ceca1091c5fd457df4204dd11792d6e
+DIST gentoolkit-0.4.7.tar.gz 3205669 BLAKE2B e5f64b85546bc10ad16e7fa42d288965539177375e8796b40df699859efa13fb98bb86aec58e60363c955b2d5e4b2e6379a7597252ee4fdbeec49559de67b328 SHA512 0fab600b4323d23e12009eeb4ade595950880a88b05bcfbfeada1a9b9af615b96d31c568285629bf6e5de7b45ed857bdf98b6261dc54974fbaf70c924e093c76
diff --git a/app-portage/gentoolkit/gentoolkit-0.4.7.ebuild b/app-portage/gentoolkit/gentoolkit-0.4.7.ebuild
new file mode 100644 (file)
index 0000000..4ecbc93
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
+PYTHON_REQ_USE="xml(+),threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of administration scripts for Gentoo"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Portage-Tools"
+SRC_URI="https://gitweb.gentoo.org/proj/gentoolkit.git/snapshot/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+DEPEND="
+       sys-apps/portage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}
+       sys-apps/gawk
+       sys-apps/gentoo-functions"
+
+python_prepare_all() {
+       python_setup
+       echo VERSION="${PVR}" "${PYTHON}" setup.py set_version
+       VERSION="${PVR}" "${PYTHON}" setup.py set_version
+       distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+}
+
+pkg_preinst() {
+       if has_version "<${CATEGORY}/${PN}-0.4.0"; then
+               SHOW_GENTOOKIT_DEV_DEPRECATED_MSG=1
+       fi
+}
+
+pkg_postinst() {
+       # Create cache directory for revdep-rebuild
+       mkdir -p -m 0755 "${EROOT}"/var/cache
+       mkdir -p -m 0700 "${EROOT}"/var/cache/revdep-rebuild
+
+       if [[ ${SHOW_GENTOOKIT_DEV_DEPRECATED_MSG} ]]; then
+               elog "Starting with version 0.4.0, ebump, ekeyword and imlate are now"
+               elog "part of the gentoolkit package."
+               elog "The gentoolkit-dev package is now deprecated in favor of a single"
+               elog "gentoolkit package.   The remaining tools from gentoolkit-dev"
+               elog "are now obsolete/unused with the git based tree."
+       fi
+
+       # Only show the elog information on a new install
+       if [[ ! ${REPLACING_VERSIONS} ]]; then
+               elog
+               elog "For further information on gentoolkit, please read the gentoolkit"
+               elog "guide: https://wiki.gentoo.org/wiki/Gentoolkit"
+               elog
+               elog "Another alternative to equery is app-portage/portage-utils"
+               elog
+               elog "Additional tools that may be of interest:"
+               elog
+               elog "    app-admin/eclean-kernel"
+               elog "    app-portage/diffmask"
+               elog "    app-portage/flaggie"
+               elog "    app-portage/install-mask"
+               elog "    app-portage/portpeek"
+               elog "    app-portage/smart-live-rebuild"
+       fi
+}