app-misc/detachtty: 11.0.0 version bump
authorWilliam Hubbs <william.hubbs@sony.com>
Fri, 18 Jan 2019 18:22:39 +0000 (12:22 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Fri, 18 Jan 2019 18:24:08 +0000 (12:24 -0600)
This was approved by monsieurp.

Closes: https://bugs.gentoo.org/675700
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: William Hubbs <williamh@gentoo.org>
app-misc/detachtty/Manifest
app-misc/detachtty/detachtty-11.0.0.ebuild [new file with mode: 0644]

index c7e55e917f32bae53a471b21aba702819827c258..7bac2284e2d2c9278e517d052d4d923797ee8b61 100644 (file)
@@ -1 +1,2 @@
+DIST detachtty-11.0.0.tar.gz 23189 BLAKE2B 734489fe35acb5bfb381b8fee1b91d60f15ec795f2ba58f5855544d913957f7da4174c15583dc4090e397c5f562e78a23c1534a741a9812980f4a9cd2d2e291e SHA512 608d68ebe9b8fae55b4295b9c50d8e9065226dbb78818535af79bd2e70cc4a831820b6c673414289548b1063843b5dc80c8b7d2371dd716a16eceb20cd064a10
 DIST detachtty_9.tar.gz 13081 BLAKE2B 28bb6a946d04717bc60ac7f65b791a8bb59a5ce1a2f7d7fabb63776538ade3fe046e874007effe7dd6ba7ebac8d739e16b0b0e2372ce4154385164d7939b498c SHA512 8ae7edc1a1c7727eb4d32a1a4327932e374ac838b441f34aee99cfe83e922f1d70383ab0aab2299808f28fea6229f5c122a7624b7ff992ab92b9c3f53483d035
diff --git a/app-misc/detachtty/detachtty-11.0.0.ebuild b/app-misc/detachtty/detachtty-11.0.0.ebuild
new file mode 100644 (file)
index 0000000..570e3b5
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Attach/detach from interactive processes across the network"
+HOMEPAGE="https://github.com/cosmos72/detachtty"
+SRC_URI="https://github.com/cosmos72/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+src_compile() {
+       emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+       dobin attachtty detachtty
+       doman "${PN}.1"
+       dosym detachtty.1 /usr/share/man/man1/attachtty.1
+       einstalldocs
+}