p/f/p/s/kernel-2.6.16+/profile.bashrc: disable pipe2, utimensat
authorBenda Xu <heroxbd@gentoo.org>
Sat, 18 Aug 2018 05:35:12 +0000 (14:35 +0900)
committerBenda Xu <heroxbd@gentoo.org>
Sat, 18 Aug 2018 05:37:23 +0000 (14:37 +0900)
  qtcore incorrectly uses kernel features without testing. Fix it.

profiles/features/prefix/standalone/kernel-2.6.16+/profile.bashrc

index e537cc0fa31907bb2642ca99bd386b314ce6decd..fb926138685dddecd3693fe81b33b3ccf201373b 100644 (file)
@@ -2,5 +2,14 @@
 
 if [[ ${CATEGORY}/${PN} == dev-util/cmake && ${EBUILD_PHASE} == configure ]]; then
     einfo "Removing utimensat outputs..."
-    sed -i '/UTIMENSAT=/d' ${S}/Source/kwsys/CMakeLists.txt
+    sed -e '/UTIMENSAT=/d' -i ${S}/Source/kwsys/CMakeLists.txt || die
+elif [[ ${CATEGORY}/${PN} == dev-qt/qtcore && ${EBUILD_PHASE} == configure ]]; then
+    einfo "Removing pipe2 definitions..."
+    sed -e '/define.*HAVE_PIPE2/d' -i ${S}/src/3rdparty/forkfd/forkfd.c || die
+    einfo "Removing utimensat calls..."
+    sed -e '/_POSIX_VERSION/s/defined(_POSIX_VERSION)/0/' -i ${S}/qmake/library/ioutils.cpp || die
 fi
+
+# Local Variables:
+# mode: shell-script
+# End: