sys-cluster/ceph: Revision bump, fix installation of python modules
authorPatrick McLean <chutzpah@gentoo.org>
Tue, 28 Feb 2017 04:29:54 +0000 (20:29 -0800)
committerPatrick McLean <chutzpah@gentoo.org>
Tue, 28 Feb 2017 04:30:23 +0000 (20:30 -0800)
For some reason the ceph build system stopped installed required python
modules for python2, and only installed them in python3. This fixes the
problem so the ceph cli tools will work again.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

sys-cluster/ceph/ceph-10.2.5-r3.ebuild [moved from sys-cluster/ceph/ceph-10.2.5-r2.ebuild with 94% similarity]

similarity index 94%
rename from sys-cluster/ceph/ceph-10.2.5-r2.ebuild
rename to sys-cluster/ceph/ceph-10.2.5-r3.ebuild
index 568216bfa42870b4ef5e3c81593b8b4a4b2ddcf0..cce9b22dd9e32a3f3e7fe2a9c43f9e9596c1b62e 100644 (file)
@@ -135,7 +135,7 @@ user_setup() {
 }
 
 emake_python_bindings() {
-       local action="${1}" params binding
+       local action="${1}" params binding module
        shift
        params=("${@}")
 
@@ -144,8 +144,15 @@ emake_python_bindings() {
                emake "${params[@]}" PYTHON="${EPYTHON}" "${binding}-pybind-${action}"
 
                # these don't work and aren't needed on python3
-               if [[ ${EBUILD_PHASE} == install ]] && python_is_python3; then
-                       rm -f "${ED}/$(python_get_sitedir)"/ceph_{argparse,volume_client}.py
+               if [[ ${EBUILD_PHASE} == install ]]; then
+                       for module in "${S}"/src/pybind/*.py; do
+                               module_basename="$(basename "${module}")"
+                               if [[ ${module_basename} == ceph_volume_client.py ]] && ! use cephfs; then
+                                       continue
+                               elif [[ ! -e "${ED}/$(python_get_sitedir)/${module_basename}" ]]; then
+                                       python_domodule ${module}
+                               fi
+                       done
                fi
        }