Initial ebuild.
authorMike Kelly <pioto@gentoo.org>
Fri, 23 Mar 2007 20:31:03 +0000 (20:31 +0000)
committerMike Kelly <pioto@gentoo.org>
Fri, 23 Mar 2007 20:31:03 +0000 (20:31 +0000)
Package-Manager: portage-2.1.2.2

media-sound/shell-fm/ChangeLog [new file with mode: 0644]
media-sound/shell-fm/files/digest-shell-fm-0.2_p191 [new file with mode: 0644]
media-sound/shell-fm/metadata.xml [new file with mode: 0644]
media-sound/shell-fm/shell-fm-0.2_p191.ebuild [new file with mode: 0644]

diff --git a/media-sound/shell-fm/ChangeLog b/media-sound/shell-fm/ChangeLog
new file mode 100644 (file)
index 0000000..0422972
--- /dev/null
@@ -0,0 +1,7 @@
+# ChangeLog for media-sound/shell-fm
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/ChangeLog,v 1.1 2007/03/23 20:31:03 pioto Exp $
+
+  23 Mar 2007; Mike Kelly <pioto@gentoo.org> +metadata.xml:
+  Initial ebuild.
+
diff --git a/media-sound/shell-fm/files/digest-shell-fm-0.2_p191 b/media-sound/shell-fm/files/digest-shell-fm-0.2_p191
new file mode 100644 (file)
index 0000000..99d2a88
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 5a22a59618b9e7b3dd7899ebbfd814d0 shell-fm-0.2_p191.tar.bz2 96480
+RMD160 87bcc906d977806a5fe567e4fd6b18cf5d7f6d7a shell-fm-0.2_p191.tar.bz2 96480
+SHA256 94593585ce0d95f9c82db5bfe119e5bfbe31aca58b7b48cf1581bb3f89c37da0 shell-fm-0.2_p191.tar.bz2 96480
diff --git a/media-sound/shell-fm/metadata.xml b/media-sound/shell-fm/metadata.xml
new file mode 100644 (file)
index 0000000..89ae8a1
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <herd>no-herd</herd>
+       <maintainer>
+               <email>pioto@gentoo.org</email>
+               <name>Mike Kelly</name>
+       </maintainer>
+       <longdescription lang="en">
+               Shell.FM is a lightweight console based player for Last.FM radio
+               streams. It's written mainly for Linux, but should be able to run on any
+               UNIX based system (even Mac OS X) with some minor tweaks.
+       </longdescription>
+</pkgmetadata>
diff --git a/media-sound/shell-fm/shell-fm-0.2_p191.ebuild b/media-sound/shell-fm/shell-fm-0.2_p191.ebuild
new file mode 100644 (file)
index 0000000..b12e365
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/shell-fm/shell-fm-0.2_p191.ebuild,v 1.1 2007/03/23 20:31:03 pioto Exp $
+
+DESCRIPTION="A lightweight console based player for Last.FM radio streams."
+HOMEPAGE="http://nex.scrapping.cc/shell-fm/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="ao"
+
+DEPEND="media-libs/libmad
+       ao? ( media-libs/libao )"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+       econf $(use_enable ao) || die 'econf failed'
+       emake || die 'emake failed'
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die 'emake install failed'
+}