sys-block/open-iscsi: Revbump to fix a space issue
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 6 May 2019 12:50:48 +0000 (14:50 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 6 May 2019 12:54:34 +0000 (14:54 +0200)
Bug: https://bugs.gentoo.org/685190
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-block/open-iscsi/files/open-iscsi-2.0.876-space_in_node-mode.patch [new file with mode: 0644]
sys-block/open-iscsi/open-iscsi-2.0.876_p20180814-r1.ebuild [moved from sys-block/open-iscsi/open-iscsi-2.0.876_p20180814.ebuild with 97% similarity]

diff --git a/sys-block/open-iscsi/files/open-iscsi-2.0.876-space_in_node-mode.patch b/sys-block/open-iscsi/files/open-iscsi-2.0.876-space_in_node-mode.patch
new file mode 100644 (file)
index 0000000..1b72eec
--- /dev/null
@@ -0,0 +1,28 @@
+From baa0cb45cfcf10a81283c191b0b236cd1a2f66ee Mon Sep 17 00:00:00 2001
+From: Lee Duncan <lduncan@suse.com>
+Date: Fri, 12 Oct 2018 09:57:20 -0700
+Subject: [PATCH] Restore space in node-mode level 0 output
+
+As part of the libopeniscsiusr update, the output
+of "iscsiadm -m node" dropped a space that needs to
+be between the portal and the target, for proper
+parsing.
+
+Fixes: 87ea50a1c3a97
+---
+ usr/iscsiadm.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/usr/iscsiadm.c b/usr/iscsiadm.c
+index e3ba03c8..25c6cdc0 100644
+--- a/usr/iscsiadm.c
++++ b/usr/iscsiadm.c
+@@ -683,7 +683,7 @@ static int login_portals(struct node_rec *pattern_rec)
+ static void print_node_flat(struct iscsi_node *node)
+ {
+-              printf("%s,%" PRIu16 "%s\n",
++              printf("%s,%" PRIu16 " %s\n",
+                      iscsi_node_portal_get(node),
+                      iscsi_node_tpgt_get(node),
+                      iscsi_node_target_name_get(node));
similarity index 97%
rename from sys-block/open-iscsi/open-iscsi-2.0.876_p20180814.ebuild
rename to sys-block/open-iscsi/open-iscsi-2.0.876_p20180814-r1.ebuild
index b111b48a68e6f887ee00af627edf8e76d56ce078..8d18bfc1ed408caec1dafa50ffdf13f2f46a2505 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI="6"
@@ -27,6 +27,7 @@ REQUIRED_USE="infiniband? ( rdma ) || ( rdma tcp )"
 PATCHES=(
        "${FILESDIR}/${PN}-2.0.876_p20180814-musl-fixes.patch"
        "${FILESDIR}/${PN}-2.0.876-Makefiles.patch"
+       "${FILESDIR}/${PN}-2.0.876-space_in_node-mode.patch" #685190
 )
 
 S="${WORKDIR}/${PN}-${MY_COMMIT}"