dev-python/regex: Remove old
authorMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:48:55 +0000 (13:48 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 4 May 2020 11:48:55 +0000 (13:48 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/regex/Manifest
dev-python/regex/regex-2017.04.05-r1.ebuild [deleted file]
dev-python/regex/regex-2017.04.05.ebuild [deleted file]

index d48fe14a357ce4d93403c4f6b2f2b5ce232a3200..1a9db46efae93f1fbfbd4ee097bfbe46e13f10de 100644 (file)
@@ -1,4 +1,3 @@
-DIST regex-2017.04.05.tar.gz 601638 BLAKE2B a7c094887b602f24e68c51c92098604c462d506b13f064beaebdec081fd28d39dac9934fface0de0444dc6145af5f4c0e8ab2cd3b65ecfc2c1ca522682b3bf95 SHA512 4c3e440e11f57e2323892e10fbed7f2c89b35771fdc970164ba69bb154dde535f6edb51a0997c924eb776c61e5efd1d04001abd343110518a89b5b7bf148ae49
 DIST regex-2019.11.1.tar.gz 669331 BLAKE2B b0b51051f88b6a171e78b281332fadf4d7e8588a76b367a86bb2754815614625738e882ffac66cb243d480b8d6920210423725ff4c1331cc199a3df7ed8b59a5 SHA512 fcb7d37f77937815428909ec3cf86785779ee80389a859f082c0f4b3c955779de6674490857737bc595f5f3a1c430cf237ba384ed54c37d254a8f0ffa1577148
 DIST regex-2020.2.20.tar.gz 681215 BLAKE2B cc23ec03dc83068320155e4e660ee27e00935d179566d007e21879506f80dd67b2c1abdd6a4dac789a239474a8b3358f1fcbcee53af91b3d2b7ef71ce19c7ab1 SHA512 0a35b9512048bd36bcbf8a03905cc77f007d204f9ed9a0aaa3d5fcd72392bf37285c35ec0f04b1520e486b651028063c799ec265782c52ca4ecf7eeb0581727a
 DIST regex-2020.4.4.tar.gz 695848 BLAKE2B 0dc41e1f1464014bcdc10b7209f7ac0506aeb6a3e09c16b4ca302619aaa8271cb06138627e8ed7f64ff80cf661eb83f07b4514828cf7fa94f21211fc42ae9f7c SHA512 95eadaaffaf87a19b31024ad3cff670d34a31de8b9be430fc276a533a584203842d1634b66a346c4aaecf2407b973bb1ae9c8ee8b48785d03bd5e45a67a271a9
diff --git a/dev-python/regex/regex-2017.04.05-r1.ebuild b/dev-python/regex/regex-2017.04.05-r1.ebuild
deleted file mode 100644 (file)
index 058bbc3..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} pypy3 )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Alternative regular expression module to replace re"
-HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
-IUSE="doc"
-
-DOCS=( README docs/UnicodeProperties.txt )
-
-python_compile() {
-       if ! python_is_python3; then
-               local CFLAGS=${CFLAGS}
-               append-cflags -fno-strict-aliasing
-       fi
-       distutils-r1_python_compile
-}
-
-python_test() {
-       local msg="tests failed under ${EPYTHON}"
-       # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
-       einfo "There is one trivial fail of test test_empty_array under pypy"
-
-       if python_is_python3; then
-               "${PYTHON}" Python3/test_regex.py || die "${msg}"
-       else
-               "${PYTHON}" Python2/test_regex.py || die "${msg}"
-       fi
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/Features.html )
-
-       distutils-r1_python_install_all
-}
diff --git a/dev-python/regex/regex-2017.04.05.ebuild b/dev-python/regex/regex-2017.04.05.ebuild
deleted file mode 100644 (file)
index 2202fd2..0000000
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 python3_{6,7} )
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Alternative regular expression module to replace re"
-HOMEPAGE="https://bitbucket.org/mrabarnett/mrab-regex"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~arm arm64 ~hppa ~ia64 ~mips ppc ppc64 s390 sparc x86"
-IUSE="doc"
-
-DOCS=( README docs/UnicodeProperties.txt )
-
-python_compile() {
-       if ! python_is_python3; then
-               local CFLAGS=${CFLAGS}
-               append-cflags -fno-strict-aliasing
-       fi
-       distutils-r1_python_compile
-}
-
-python_test() {
-       local msg="tests failed under ${EPYTHON}"
-       # https://bitbucket.org/mrabarnett/mrab-regex/issue/145/1-fail-in-testsuite-under-pypy
-       einfo "There is one trivial fail of test test_empty_array under pypy"
-
-       if python_is_python3; then
-               "${PYTHON}" Python3/test_regex.py || die $msg
-       else
-               "${PYTHON}" Python2/test_regex.py || die $msg
-       fi
-}
-
-python_install_all() {
-       local DOCS="${DOCS} docs/UnicodeProperties.txt"
-       use doc && local HTML_DOCS=( docs/Features.html )
-
-       distutils-r1_python_install_all
-}