sys-power/acpi_call: fix qa warning
authorConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 15:51:08 +0000 (17:51 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 16:22:12 +0000 (18:22 +0200)
Also bumped to EAPI=7.

Closes: https://bugs.gentoo.org/694400
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
sys-power/acpi_call/acpi_call-3.17-r1.ebuild [new file with mode: 0644]

diff --git a/sys-power/acpi_call/acpi_call-3.17-r1.ebuild b/sys-power/acpi_call/acpi_call-3.17-r1.ebuild
new file mode 100644 (file)
index 0000000..87ae131
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info linux-mod
+
+HOMEPAGE="https://github.com/teleshoes/acpi_call"
+if [ "${PV}" = "9999" ]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/teleshoes/acpi_call.git"
+       KEYWORDS=""
+else
+       SRC_URI="https://github.com/teleshoes/acpi_call/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A kernel module that enables you to call ACPI methods"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+BUILD_TARGETS="default"
+CONFIG_CHECK="ACPI"
+MODULE_NAMES="acpi_call(misc:${S})"
+
+PATCHES=(
+       "${FILESDIR}/${P}-linux-4.12.patch"
+       "${FILESDIR}/${P}-linux-4.14.patch"
+       "${FILESDIR}/${P}-linux-5.6.patch"
+)
+
+src_compile() {
+       BUILD_PARAMS="KDIR=${KV_OUT_DIR} M=${S}"
+       linux-mod_src_compile
+}