www-apache/mod_h2: 1.15.8 version bump
authorCraig Andrews <candrews@gentoo.org>
Fri, 17 Apr 2020 13:05:07 +0000 (09:05 -0400)
committerCraig Andrews <candrews@gentoo.org>
Fri, 17 Apr 2020 13:05:33 +0000 (09:05 -0400)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Craig Andrews <candrews@gentoo.org>
www-apache/mod_h2/Manifest
www-apache/mod_h2/mod_h2-1.15.8.ebuild [new file with mode: 0644]

index 8848df3b4ec84fb8a849812eb7f2701066dce833..2ff69a1137029996cad1ebb88e33e82f0bff900a 100644 (file)
@@ -1 +1,2 @@
 DIST mod_http2-1.15.7.tar.gz 1042030 BLAKE2B 5252e15fbc71845db557d567daba63452df0693baad18f8b83f937adbd760f1fa931fbf663f1f5ec475760e75fc132fb0de63784e046092669b1d8fb44d96e9a SHA512 effe0a8f41603865a9dceea6fa109a924e6f2f904a2a02ebf10a20e0315f248cfaf91d4b2a0d6168ee94fb0f4af2680a6992c43cc91b0bf47a13d739b4cf9228
+DIST mod_http2-1.15.8.tar.gz 1029471 BLAKE2B 10dcbafeee8be71858f1eace6c65b31d4a06b9598ba0ed8dd0d191c6fa8eb0475e0b9bd9f52a09fdf3430b18c770f0cd41057e9661f252d11df0edab8189cb26 SHA512 47ee0ef6d5e6cdce8b5d35cdca107331378c3d3ccb6d7b6c36eea8e04dda3d5665233aa7834f122d2069d7c81a833bff08e3f0a279d4a5a0bd1ec6b366696fd3
diff --git a/www-apache/mod_h2/mod_h2-1.15.8.ebuild b/www-apache/mod_h2/mod_h2-1.15.8.ebuild
new file mode 100644 (file)
index 0000000..b5be17b
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit apache-module autotools
+
+MY_P="${PN/h2/http2}-${PV}"
+
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/icing/mod_h2.git"
+       inherit git-r3
+else
+       S="${WORKDIR}/${MY_P}"
+       SRC_URI="https://github.com/icing/mod_h2/releases/download/v${PV}/${MY_P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="HTTP/2 module for Apache"
+HOMEPAGE="https://github.com/icing/mod_h2"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="ssl"
+
+RDEPEND=">=net-libs/nghttp2-1.0
+       >=www-servers/apache-2.4.20[-apache2_modules_http2,ssl?]"
+DEPEND="${RDEPEND}"
+
+need_apache2_4
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_compile() {
+       default
+}
+
+src_install() {
+       default
+
+       APACHE2_MOD_DEFINE="HTTP2"
+       insinto "${APACHE_MODULES_CONFDIR}"
+       newins "${FILESDIR}/mod_http2.conf" "41_mod_http2.conf"
+}