media-libs/libbluray: Bump to 1.0.0 and add subslot
authorAlexis Ballier <aballier@gentoo.org>
Sat, 4 Mar 2017 13:20:06 +0000 (14:20 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Sat, 4 Mar 2017 13:36:49 +0000 (14:36 +0100)
Package-Manager: Portage-2.3.4, Repoman-2.3.2

media-libs/libbluray/Manifest
media-libs/libbluray/libbluray-1.0.0.ebuild [new file with mode: 0644]
media-libs/libbluray/libbluray-9999.ebuild

index 318f16025520e4fcfd993b3af207b238c08196c0..46dd4f1b9dbd8efbb34add1898928d989a122812 100644 (file)
@@ -1 +1,2 @@
 DIST libbluray-0.9.3.tar.bz2 722686 SHA256 a6366614ec45484b51fe94fcd1975b3b8716f90f038a33b24d59978de3863ce0 SHA512 1e308b85c51d43b23b186fdd2631f963d4c25de8aff29f335e131b32a175434ee21460a7aa470c508ad13662cf9052649bb4eb974dbd709eb9e6797fb84e0823 WHIRLPOOL b121e75b68738c057ea3e5240523ca2c427c60436e3f12b5ed0817a673ec26573ea45d5d788e464f234eaa254fadcd583b81c2d30970131e2b5eb46b4c279632
+DIST libbluray-1.0.0.tar.bz2 713973 SHA256 f7e3add335c7bbef45824fcd2249a9bf293868598c13f8479352c44ec95374cc SHA512 fcf2193c3b76f3436bc88ce8853cac16f29c3bb6c66447109c14202a41ea938cb6814502a8f724fb1b31add6bd36b42d3aed3eb4a8010c123537e073bd7a0be1 WHIRLPOOL 333d100a8a7214277f07f763b2e41df0289cec4e3f7a713c562e225328b0379996fa5acb716b8e5d365f842a065b9a010ec617dc72c1a018556ff9d06ab65dca
diff --git a/media-libs/libbluray/libbluray-1.0.0.ebuild b/media-libs/libbluray/libbluray-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..7c17336
--- /dev/null
@@ -0,0 +1,93 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ "${PV#9999}" != "${PV}" ]] ; then
+       inherit git-r3
+       KEYWORDS=""
+       EGIT_REPO_URI="git://git.videolan.org/libbluray.git"
+       SRC_URI=""
+else
+       KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+       SRC_URI="http://ftp.videolan.org/pub/videolan/libbluray/${PV}/${P}.tar.bz2"
+fi
+
+inherit autotools java-pkg-opt-2 flag-o-matic eutils multilib-minimal
+
+DESCRIPTION="Blu-ray playback libraries"
+HOMEPAGE="http://www.videolan.org/developers/libbluray.html"
+
+LICENSE="LGPL-2.1"
+SLOT="0/2"
+IUSE="aacs bdplus +fontconfig java static-libs +truetype udf utils +xml"
+
+COMMON_DEPEND="
+       xml? ( >=dev-libs/libxml2-2.9.1-r4[${MULTILIB_USEDEP}] )
+       fontconfig? ( >=media-libs/fontconfig-2.10.92[${MULTILIB_USEDEP}] )
+       truetype? ( >=media-libs/freetype-2.5.0.1:2[${MULTILIB_USEDEP}] )
+"
+RDEPEND="
+       ${COMMON_DEPEND}
+       aacs? ( >=media-libs/libaacs-0.6.0[${MULTILIB_USEDEP}] )
+       bdplus? ( media-libs/libbdplus[${MULTILIB_USEDEP}] )
+       java? ( >=virtual/jre-1.6 )
+"
+DEPEND="
+       ${COMMON_DEPEND}
+       java? (
+               >=virtual/jdk-1.6
+               dev-java/ant-core
+       )
+       virtual/pkgconfig
+"
+
+DOCS=( ChangeLog README.txt )
+
+src_prepare() {
+       default
+
+       if use java ; then
+               export JDK_HOME="$(java-config -g JAVA_HOME)"
+
+               # don't install a duplicate jar file
+               sed -i '/^jar_DATA/d' Makefile.am || die
+
+               java-pkg-opt-2_src_prepare
+       fi
+
+       eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE="${S}" econf \
+               --disable-optimizations \
+               $(multilib_native_use_enable utils examples) \
+               $(multilib_native_use_enable java bdjava) \
+               $(use_with fontconfig) \
+               $(use_with truetype freetype) \
+               $(use_enable static-libs static) \
+               $(use_enable udf) \
+               $(use_with xml libxml2)
+}
+
+multilib_src_install() {
+       emake DESTDIR="${D}" install
+
+       if multilib_is_native_abi && use utils; then
+               cd .libs/
+               dobin index_dump mobj_dump mpls_dump bd_info bdsplice clpi_dump hdmv_test libbluray_test list_titles sound_dump
+               if use java; then
+                       dobin bdj_test
+               fi
+       fi
+
+       if multilib_is_native_abi && use java; then
+               java-pkg_dojar "${BUILD_DIR}"/.libs/${PN}-j2se-*.jar
+       fi
+}
+
+multilib_src_install_all() {
+       einstalldocs
+       prune_libtool_files
+}
index f67ce8cfa4ccdbc4bac97c70a081f752080dbe86..7c17336fde6f5623c8b93a78b23905fe6142d4e6 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -19,7 +19,7 @@ DESCRIPTION="Blu-ray playback libraries"
 HOMEPAGE="http://www.videolan.org/developers/libbluray.html"
 
 LICENSE="LGPL-2.1"
-SLOT="0"
+SLOT="0/2"
 IUSE="aacs bdplus +fontconfig java static-libs +truetype udf utils +xml"
 
 COMMON_DEPEND="