app-accessibility/at-spi2-atk: bump to 2.34.2
authorMart Raudsepp <leio@gentoo.org>
Sat, 14 Mar 2020 22:08:02 +0000 (00:08 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 14 Mar 2020 22:32:34 +0000 (00:32 +0200)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
app-accessibility/at-spi2-atk/Manifest
app-accessibility/at-spi2-atk/at-spi2-atk-2.34.2.ebuild [new file with mode: 0644]

index 34daef6d086497450b1015ced6d0081492abb4f0..a4e57d26a5428e71c5fcfda0e0203729fbcc2a13 100644 (file)
@@ -1,2 +1,3 @@
 DIST at-spi2-atk-2.32.0.tar.xz 94952 BLAKE2B 972bb32590a51549eb8b0b3c46a068e95cc43783f0f0e31ca3663ff1669196a88def63342c01d056d45d6f4fb4bcc2127b50a49be37fd45d33aa1daeadca5172 SHA512 095ceaa33d5b35f1f4f81a31bea00487c054493cb29d4fdbcf74331ec8d1b9570dc7cb93e1cc06da9ea3f5805e7a3a9e7bf80cfdbce86a1822c2a46327109393
 DIST at-spi2-atk-2.34.0.tar.xz 96116 BLAKE2B 242b29b988d97b06ca85495be77f9c4cf1c621d9ff977cd73ea37f97b42fc636474df34429e7397fb3f91d3d11b14ce1b3de5d68c0b30f85877f444c78389564 SHA512 515ad4d0a000fa47a7848f3ea9f95f8e0c582f9d9876725deb8e521c60e290f73655445456e6c238f382cb8773b56db2795c221029ec931bad68395326b6bb04
+DIST at-spi2-atk-2.34.2.tar.xz 96608 BLAKE2B 4a3ef71580f4eaf3ea0846c8a6909b686f7ae0c7202918f3e11de019fa7290dada5a2eb3f495ce476bb56a28787967fa87fe74d422d4144e7555541ef99911da SHA512 59e7ad5c944748ca00af8b0a9df03c9ffbc6afae6e65c25a2566a9e2a30e66724c4492076be1730c2894c636f82c795c533669572584d8d5675f68b349ad16c4
diff --git a/app-accessibility/at-spi2-atk/at-spi2-atk-2.34.2.ebuild b/app-accessibility/at-spi2-atk/at-spi2-atk-2.34.2.ebuild
new file mode 100644 (file)
index 0000000..16a5d64
--- /dev/null
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome.org meson multilib-minimal virtualx xdg
+
+DESCRIPTION="Gtk module for bridging AT-SPI to Atk"
+HOMEPAGE="https://wiki.gnome.org/Accessibility"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+       >=dev-libs/glib-2.32:2[${MULTILIB_USEDEP}]
+       >=dev-libs/atk-2.33.3[${MULTILIB_USEDEP}]
+       >=app-accessibility/at-spi2-core-2.33.2[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       virtual/pkgconfig[${MULTILIB_USEDEP}]
+       test? ( >=dev-libs/libxml2-2.9.1 )
+"
+
+multilib_src_configure() {
+       meson_src_configure
+}
+
+multilib_src_compile() {
+       meson_src_compile
+}
+
+multilib_src_test() {
+       virtx dbus-run-session meson test -C "${BUILD_DIR}"
+}
+
+multilib_src_install() {
+       meson_src_install
+}