projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
09adb39
)
dev-python/kiwisolver: Remove world write permission from files
author
Justin Lecher
<jlec@gentoo.org>
Tue, 29 Sep 2015 07:21:36 +0000
(09:21 +0200)
committer
Justin Lecher
<jlec@gentoo.org>
Tue, 29 Sep 2015 07:28:16 +0000
(09:28 +0200)
Package-Manager: portage-2.2.22
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/kiwisolver/kiwisolver-0.1.3.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/kiwisolver/kiwisolver-0.1.3.ebuild
b/dev-python/kiwisolver/kiwisolver-0.1.3.ebuild
index 7303e4b639c851b3e38277a682535ffefa969c01..5ffa8f4568b9ee60ff5ff4e1f3ecfed948dbba7c 100644
(file)
--- a/
dev-python/kiwisolver/kiwisolver-0.1.3.ebuild
+++ b/
dev-python/kiwisolver/kiwisolver-0.1.3.ebuild
@@
-16,5
+16,11
@@
LICENSE="Clear-BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-DEPEND="app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ chmod o-w *egg*/* || die
+ distutils-r1_python_prepare_all
+}