dev-ml/dns-lwt: import split package from ocaml-dns
authorAlexis Ballier <aballier@gentoo.org>
Tue, 25 Jul 2017 13:06:12 +0000 (15:06 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 25 Jul 2017 13:12:22 +0000 (15:12 +0200)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-ml/dns-lwt/Manifest [new file with mode: 0644]
dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild [new file with mode: 0644]
dev-ml/dns-lwt/metadata.xml [new file with mode: 0644]

diff --git a/dev-ml/dns-lwt/Manifest b/dev-ml/dns-lwt/Manifest
new file mode 100644 (file)
index 0000000..467ed0a
--- /dev/null
@@ -0,0 +1 @@
+DIST ocaml-dns-1.0.0.tar.gz 99161 SHA256 823410badaf2faf54ca8a59472b0ad82c4db9fe4ef92f6809061baa826851226 SHA512 199653605e985851dcaafc94f1efeba5c261c29cd5e5f8eaebc9f7d25a05c43adcf7620efb291b22f9549f7c05f8ac3f6abfbcf40e0d7762bd2f7cd623ebcb1c WHIRLPOOL e7c26857270d92be2e8e068ac29119ef5d82d52fd739b8304e84c595d6a6e7fc11c22ed98e4a6d99a20f4e9d1d6b28dbc76c333d6b464bbd1dc4d37597cfe66c
diff --git a/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild b/dev-ml/dns-lwt/dns-lwt-1.0.0.ebuild
new file mode 100644 (file)
index 0000000..dd4d0e5
--- /dev/null
@@ -0,0 +1,52 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+MY_P=ocaml-dns-${PV}
+
+DESCRIPTION="Lwt support of OCaml DNS"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/ocaml-dns/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+       >=dev-lang/ocaml-4:=
+       dev-ml/lwt:=
+       dev-ml/ocaml-dns:=
+       dev-ml/mirage-profile:=
+"
+DEPEND="
+       dev-ml/jbuilder
+       dev-ml/opam
+       test? (
+               dev-ml/dns-lwt-unix
+       )
+       ${RDEPEND}
+"
+# do not work
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+src_compile() {
+       jbuilder build @install -p ${PN} || die
+}
+
+src_test() {
+       jbuilder runtest -p ${PN} || die
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+}
diff --git a/dev-ml/dns-lwt/metadata.xml b/dev-ml/dns-lwt/metadata.xml
new file mode 100644 (file)
index 0000000..2f4ef14
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+   <maintainer type="project">
+        <email>ml@gentoo.org</email>
+        <name>Gentoo ML Project</name>
+    </maintainer>
+    <upstream>
+        <remote-id type="github">mirage/ocaml-dns</remote-id>
+    </upstream>
+</pkgmetadata>