sys-apps/pkgcore: version bump to 0.10.12
authorTim Harder <radhermit@gentoo.org>
Thu, 16 Apr 2020 01:29:56 +0000 (19:29 -0600)
committerTim Harder <radhermit@gentoo.org>
Thu, 16 Apr 2020 01:30:18 +0000 (19:30 -0600)
Signed-off-by: Tim Harder <radhermit@gentoo.org>
sys-apps/pkgcore/Manifest
sys-apps/pkgcore/pkgcore-0.10.12.ebuild [new file with mode: 0644]

index c2e6f075f58ec0da2fb2a72ea9af39f6598a4559..f7697806695d01866a02d40a3ac0768a6d5cb1f0 100644 (file)
@@ -1 +1,2 @@
 DIST pkgcore-0.10.11.tar.gz 648060 BLAKE2B 20bb4666a9adfcca090758ec427054155273a5b73bd3170ce1d52c21ca300be3c8b8c0c2f6ce4f8e2c07caa0d5f741117eef4d474265afbc016cc66b0f5217cf SHA512 9c8e839b0a0027f5182aed2b56eb6bded34fa365dc0df82d759f349778756951547aa9887f53343831018cabf59cd3dbd96a866998d482ae6f85e19fe7d82baa
+DIST pkgcore-0.10.12.tar.gz 646922 BLAKE2B f3251b1a0d773e83d60f15598c2c5679a48a1e1dd81b82956ffb26ef72c25296903d64deeb0e91d95ae26832d0e08e3cdfcb68b95bbcd87acf8ed448a4f4ae56 SHA512 f6f900fc7f77a683c398c874c51eddb387f9aed572d5fce38f4856faa71f4f8e870b1bc276a87f15967733fa6ec7c8345f2d6b777897694537fa1e9165b1433c
diff --git a/sys-apps/pkgcore/pkgcore-0.10.12.ebuild b/sys-apps/pkgcore/pkgcore-0.10.12.ebuild
new file mode 100644 (file)
index 0000000..801f60a
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{6,7,8} )
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1
+
+if [[ ${PV} == *9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/pkgcore/pkgcore.git"
+       inherit git-r3
+else
+       KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+fi
+
+DESCRIPTION="a framework for package management"
+HOMEPAGE="https://github.com/pkgcore/pkgcore"
+
+LICENSE="BSD MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+if [[ ${PV} == *9999 ]]; then
+       RDEPEND+=" ~dev-python/snakeoil-9999[${PYTHON_USEDEP}]"
+else
+       RDEPEND+=" >=dev-python/snakeoil-0.8.7[${PYTHON_USEDEP}]"
+fi
+DEPEND="${RDEPEND}
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+"
+
+python_test() {
+       esetup.py test
+}
+
+python_install_all() {
+       local DOCS=( AUTHORS NEWS.rst )
+       [[ ${PV} == *9999 ]] || doman man/*
+       distutils-r1_python_install_all
+}