media-gfx/simple-scan: Fix unasigned variable build issue
authorPacho Ramos <pacho@gentoo.org>
Sun, 10 Nov 2019 17:34:33 +0000 (18:34 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 10 Nov 2019 17:36:51 +0000 (18:36 +0100)
Package-Manager: Portage-2.3.79, Repoman-2.3.18
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
media-gfx/simple-scan/files/simple-scan-3.32.2-unasigned-variable.patch [new file with mode: 0644]
media-gfx/simple-scan/simple-scan-3.32.2.ebuild

diff --git a/media-gfx/simple-scan/files/simple-scan-3.32.2-unasigned-variable.patch b/media-gfx/simple-scan/files/simple-scan-3.32.2-unasigned-variable.patch
new file mode 100644 (file)
index 0000000..9ba4aa7
--- /dev/null
@@ -0,0 +1,39 @@
+From 47d3532459863e3b0bc1c7fd3a200f612863c814 Mon Sep 17 00:00:00 2001
+From: Rico Tzschichholz <ricotz@ubuntu.com>
+Date: Sat, 14 Sep 2019 20:03:47 +0200
+Subject: [PATCH] libwepmix: Fix use of possibly unassigned local variable
+ 'data'
+
+---
+ src/libwebpmux.vapi | 8 ++------
+ 1 file changed, 2 insertions(+), 6 deletions(-)
+
+diff --git a/src/libwebpmux.vapi b/src/libwebpmux.vapi
+index f2461a2..42d2886 100644
+--- a/src/libwebpmux.vapi
++++ b/src/libwebpmux.vapi
+@@ -61,9 +61,7 @@ namespace WebP
+         [CCode (cname = "vala_set_image")]
+         public MuxError set_image (uint8[] bitstream, bool copy_data)
+         {
+-                Data data;
+-                data.bytes = bitstream;
+-                data.size = bitstream.length;
++                Data data = { bitstream, bitstream.length };
+                 return _set_image (data, copy_data);
+         }
+@@ -89,9 +87,7 @@ namespace WebP
+         public MuxError set_chunk (string fourcc, uint8[] chunk_data, bool copy_data)
+         requires (fourcc.length == 4)
+         {
+-            Data data;
+-            data.bytes = chunk_data;
+-            data.size = chunk_data.length;
++            Data data = { chunk_data ,chunk_data.length };
+             return _set_chunk ((uchar[]) fourcc, data, copy_data);
+         }
+-- 
+2.22.0
+
index c3f42c9f23b32362d9259cab280262e2994cf40e..2c9045ad83f21d94a413c98f9b226a67784b0b05 100644 (file)
@@ -3,6 +3,7 @@
 
 EAPI=6
 VALA_MIN_API_VERSION="0.34"
+
 inherit gnome.org gnome2-utils meson vala xdg
 
 DESCRIPTION="Simple document scanning utility"
@@ -43,6 +44,9 @@ DEPEND="${COMMON_DEPEND}
 PATCHES=(
        # Add control for optional dependencies
        "${FILESDIR}"/3.26-add-control-optional-deps.patch
+       # libwepmix: Fix use of possibly unassigned local variable 'data'
+       # (from 3.34 branch)
+       "${FILESDIR}"/${PN}-3.32.2-unasigned-variable.patch
 )
 
 src_prepare() {