x11-misc/xnots: Live ebuild.
authorJeroen Roovers <jer@gentoo.org>
Wed, 16 Sep 2015 03:53:54 +0000 (05:53 +0200)
committerJeroen Roovers <jer@gentoo.org>
Wed, 16 Sep 2015 03:53:54 +0000 (05:53 +0200)
Package-Manager: portage-2.2.20.1

x11-misc/xnots/xnots-0.2.1-r1.ebuild
x11-misc/xnots/xnots-9999.ebuild [new file with mode: 0644]

index 89f8649b8da7c8f510042265930342aec467ef22..ee11e5f09c33873574dc98b5bb9939f62f951187 100644 (file)
@@ -6,7 +6,7 @@ EAPI=5
 inherit toolchain-funcs
 
 DESCRIPTION="A desktop sticky note program for the unix geek"
-HOMEPAGE="http://xnots.sourceforge.net"
+HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
 SRC_URI="mirror://sourceforge/xnots/${P}.tar.gz"
 
 LICENSE="GPL-2"
diff --git a/x11-misc/xnots/xnots-9999.ebuild b/x11-misc/xnots/xnots-9999.ebuild
new file mode 100644 (file)
index 0000000..d30b43e
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="A desktop sticky note program for the unix geek"
+HOMEPAGE="http://xnots.sourceforge.net https://github.com/thePalindrome/xnots"
+EGIT_REPO_URI="https://github.com/thePalindrome/xnots"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="vim-syntax"
+
+RDEPEND="x11-libs/libX11
+       x11-libs/libXext
+       x11-libs/libXrender
+       x11-libs/libXrandr
+       x11-libs/pango[X]"
+
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       x11-proto/xextproto
+       x11-proto/renderproto
+       x11-proto/randrproto"
+
+src_prepare() {
+       sed -i -e 's|LICENCE||g' Makefile || die
+}
+
+src_compile() {
+       emake CC="$(tc-getCC)" NO_DEBUG=1
+}
+
+src_install() {
+       emake \
+               DESTDIR="${D}" \
+               docdir=/usr/share/doc/${PF} \
+               mandir=/usr/share/man \
+               prefix=/usr \
+               install
+       if use vim-syntax; then
+               insinto /usr/share/vim/vimfiles/syntax
+               doins etc/xnots.vim
+       fi
+}