Don't ignore CVS/Entries.IO_error when not in commit mode. v2.2_rc62
authorZac Medico <zmedico@gentoo.org>
Fri, 29 Jan 2010 19:07:38 +0000 (19:07 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 29 Jan 2010 19:07:38 +0000 (19:07 -0000)
svn path=/main/trunk/; revision=15272

bin/repoman

index 193cc1e88633d2d792972956cc0ac3b3090ae70d..95a44f0ff282875318acd6fd7ba062feaa4088d0 100755 (executable)
@@ -1157,12 +1157,11 @@ for x in scanlist:
                                                if l[-7:] == ".ebuild":
                                                        eadded.append(os.path.basename(l[:-7]))
                except IOError:
-                       if options.mode == 'commit':
-                               if vcs == "cvs":
-                                       stats["CVS/Entries.IO_error"] += 1
-                                       fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
-                               else:
-                                       raise
+                       if vcs == "cvs":
+                               stats["CVS/Entries.IO_error"] += 1
+                               fails["CVS/Entries.IO_error"].append(checkdir+"/CVS/Entries")
+                       else:
+                               raise
                        continue
 
        mf = Manifest(checkdir, repoman_settings["DISTDIR"])