dev-python/os-resource-classes: 0.5.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Sun, 20 Oct 2019 23:04:05 +0000 (18:04 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Mon, 21 Oct 2019 00:18:54 +0000 (19:18 -0500)
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/os-resource-classes/Manifest
dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild [new file with mode: 0644]

index e0334fd6f4cd1f77d10cd1e8f256b3aabacf2a51..993f2c21cb4ff59ad236188c43ad06e3d6c055d4 100644 (file)
@@ -1 +1,2 @@
 DIST os-resource-classes-0.3.0.tar.gz 15371 BLAKE2B 93d9f97cc3ea546e56384684da086e284c6d4c575e8232ddb2655a98fc1cc37e6cf454f50890bffccc625342cb7bbc020df8f2a2a262a2888b854425ae2ac6f3 SHA512 6b347fde11dd0d11784a6e80ff148385b33e3f31545d6379693af611cd1d65d5cb54721c7fa599fc49b1f8e6a07ecf85ee33c30d09dc647da07fd4f67f6c5813
+DIST os-resource-classes-0.5.0.tar.gz 15949 BLAKE2B 7cef19c63a27723fdf0037224205c9df545f24c2ada020d196928707945a7acbca7619a98ca6e9585edb92b1ebb7259ea5c9811ae6d1daf18a90a92ce60661ce SHA512 112548db1daf0c31fe4304cac3834d588e531102620f0e55f648cca81724eddddc05acce4cdf3fd468b38a44dbbecea43152903c1df3a809103a7f1b947b9cd7
diff --git a/dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild b/dev-python/os-resource-classes/os-resource-classes-0.5.0.ebuild
new file mode 100644 (file)
index 0000000..ab12161
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="A list of standardized resource classes for OpenStack."
+HOMEPAGE="https://github.com/openstack/os-resource-classes"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+       !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       ${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/six-1.10.0[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       sed -i '/^hacking/d' test-requirements.txt || die
+       distutils-r1_python_prepare_all
+}