echangelog: Update copyright in other files too (except binaries and
authoridl0r <idl0r@gentoo.org>
Mon, 17 May 2010 10:33:09 +0000 (10:33 -0000)
committeridl0r <idl0r@gentoo.org>
Mon, 17 May 2010 10:33:09 +0000 (10:33 -0000)
diff/patches), bug 285520.

svn path=/trunk/gentoolkit-dev/; revision=783

ChangeLog
src/echangelog/echangelog

index 39965ec91b4a982dafb046b291a64a94b39c2504..1abf82028eb0e8d8643ec543fc96d22b7790f7e5 100644 (file)
--- a/ChangeLog
+++ b/ChangeLog
@@ -1,3 +1,7 @@
+2010-05-17: Christian Ruppert <idl0r@gentoo.org>
+       * echangelog: Update copyright in other files too (except binaries and
+                       diff/patches), bug 285520.
+
 2010-04-18: Christian Ruppert <idl0r@gentoo.org>
        src/echangelog/echangelog: Fix bazaar MOVED/MODIFIED, thanks to Serkan
        Kaba <serkan@gentoo.org>, bug 315931.
index a43acd4f536ac769d09bedb10285bb53b202c8a6..b08b2eaae235f4df84c874f2ecdb70f07885ae57 100755 (executable)
@@ -208,6 +208,16 @@ sub mypush(\@@) {
        }
 }
 
+sub update_copyright {
+       my ($t) = @_;
+       (my $year = $date) =~ s/.* //;
+
+       $t =~ s/^# Copyright \d+(?= )/$&-$year/m or
+       $t =~ s/^(# Copyright) \d+-(\d+)/$1 1999-$year/m;
+
+       return $t;
+}
+
 GetOptions(
        'help' => \$opt_help,
        'no-strict' => \$opt_nostrict,
@@ -733,16 +743,6 @@ if (grep(/\.ebuild$/, @files)) {
        $text = update_cat_pn($text);
 }
 
-sub update_copyright {
-       my ($t) = @_;
-       (my $year = $date) =~ s/.* //;
-
-       $t =~ s/^# Copyright \d+(?= )/$&-$year/m or
-       $t =~ s/^(# Copyright) \d+-(\d+)/$1 1999-$year/m;
-
-       return $t;
-}
-
 # Update the copyright year in the ChangeLog
 $text = update_copyright($text);
 
@@ -751,11 +751,12 @@ open O, '>ChangeLog.new' or die "Can't open ChangeLog.new for output: $!\n";
 print O $text            or die "Can't write ChangeLog.new: $!\n";
 close O                  or die "Can't close ChangeLog.new: $!\n";
 
-# Update affected ebuild copyright dates.  There is no reason to update the
-# copyright lines on ebuilds that haven't changed.  I verified this with an IP
-# lawyer.
-for my $e (grep /\.ebuild$/, @files) {
-       if (-s $e) {
+
+# Update affected ebuilds and some other files copyright dates.  There is no reason to update the
+# copyright lines on ebuilds that haven't changed. I verified this with an IP
+# lawyer. (patches/diffs and binary files are excluded)
+for my $e (grep(!/\.(patch|diff)$/, @files)) {
+       if (-s $e && ! -B $e) {
                my ($etext, $netext);
 
                open E, "<$e" or warn("Can't read $e to update copyright year\n"), next;