dev-python/flask-babel: Remove old
authorMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:41:34 +0000 (13:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 25 Mar 2020 12:59:31 +0000 (13:59 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/flask-babel/flask-babel-0.11.2-r1.ebuild [deleted file]

diff --git a/dev-python/flask-babel/flask-babel-0.11.2-r1.ebuild b/dev-python/flask-babel/flask-babel-0.11.2-r1.ebuild
deleted file mode 100644 (file)
index a91895d..0000000
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( pypy3 python3_6 )
-
-inherit distutils-r1
-
-MY_PN="Flask-Babel"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="i18n and l10n support for Flask based on Babel and pytz"
-HOMEPAGE="https://pythonhosted.org/Flask-Babel/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
-       dev-python/Babel[${PYTHON_USEDEP}]
-       dev-python/pytz[${PYTHON_USEDEP}]
-       >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/nose[${PYTHON_USEDEP}]
-       )"
-
-S="${WORKDIR}/${MY_P}"
-
-python_prepare_all() {
-       sed -i -e "s/'sphinx.ext.intersphinx'//" \
-               -e '/^html_theme =/,/^}/d' docs/conf.py || die
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       if use doc; then
-               sphinx-build docs docs/_build/html || die
-               HTML_DOCS=( docs/_build/html/. )
-       fi
-}
-
-python_test() {
-       nosetests || die "Tests failed under ${EPYTHON}"
-}