dev-ruby/tty-color: add 0.4.3
authorHans de Graaff <graaff@gentoo.org>
Sat, 15 Jun 2019 05:46:04 +0000 (07:46 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 15 Jun 2019 09:55:35 +0000 (11:55 +0200)
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-ruby/tty-color/Manifest
dev-ruby/tty-color/tty-color-0.4.3.ebuild [new file with mode: 0644]

index ddd86e66b43fc6a1e64b1e87ce193fd5a8d32b96..b12ec93129c86e16da4b550b76d6a54a48112c91 100644 (file)
@@ -1 +1,2 @@
+DIST tty-color-0.4.3.gem 11776 BLAKE2B 4e51a41fb97b343c22a6ae832a449905fc215b7e218a31c993a47c66c66c049f70ce0da163d27f593309c6e49c014badc378ea89dec42c94ce6ba9e088798952 SHA512 4447c02f9b738f4fbecc14149d6c09da2da36c489d118f7d18b85f48b9c22b7939e5c62a32048f1a0c958533be15ead3952c72ea03fd1d06b23b1ed29beadcd8
 DIST tty-color-0.5.0.gem 11776 BLAKE2B fc22689783c86b5d18bd3134b198b2bdf50563bc14a25b8a02611ac6a46f494c86b17ff1307089a87ad92442d99da3d408b4907b83f3c67f495a66ceaaddc2ee SHA512 998da9196055b011edf8b20595e548447d7a3cda3555a61c2645dac618dcebf8fcd3b257ae8948f93fd7720956f6dc2b554fb5521a8847017c4a2ab2e2b74e73
diff --git a/dev-ruby/tty-color/tty-color-0.4.3.ebuild b/dev-ruby/tty-color/tty-color-0.4.3.ebuild
new file mode 100644 (file)
index 0000000..af90325
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Terminal color capabilities detection"
+HOMEPAGE="https://github.com/piotrmurach/tty-color"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+       echo '-rspec_helper' > .rspec || die
+}