net-misc/teamviewer: Version bump (v15.3.2682)
authorMikle Kolyada <zlogene@gentoo.org>
Mon, 16 Mar 2020 10:02:23 +0000 (13:02 +0300)
committerMikle Kolyada <zlogene@gentoo.org>
Mon, 16 Mar 2020 10:02:54 +0000 (13:02 +0300)
Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
net-misc/teamviewer/Manifest
net-misc/teamviewer/teamviewer-15.3.2682.ebuild [new file with mode: 0644]

index 1130c1540e430bd572b5a372133be2d9915f9b47..a3e17f444bd1d1aabe6631306d56babc69c9f24a 100644 (file)
@@ -4,3 +4,5 @@ DIST teamviewer_15.1.3937_amd64.tar.xz 12898448 BLAKE2B fea1d64c04c5c4f04237ab63
 DIST teamviewer_15.1.3937_i386.tar.xz 13443796 BLAKE2B aa9c5f3cd42a123c38a567a117c919c829e089e4c81cf4b6fca0559351895c3824b7a117ac7dc64c9f1129e0cd44dd2347e57644080559a86640a9d8bffbe62a SHA512 8054e5e3901d60bbf210b03209da8afaab03ba95529d1a107a23401a7561c5ee0c33a43837f84490667f0fa282fe8a74087473b7f51f604b675e87d87522302d
 DIST teamviewer_15.2.2756_amd64.tar.xz 12925536 BLAKE2B 94029edb0c333bbab3dc8ed0ad881fc5e5de820a4a92f578781456315d746d1fbf94e7b4d1b651c250c23a32247d2ccf9ba9f9fe839ba188e572ffacebd71630 SHA512 9227388efd819689bd852de62b1dbe122e7081cbec19ba4c96546dd8f889c8b87884fe53231f00f39030882bc150aefaaeedab7d9b3ff28315273d95303eaf78
 DIST teamviewer_15.2.2756_i386.tar.xz 13456056 BLAKE2B cd41db000d5d7fe67f888026146affcfd08495c4e275b1e66ffcc71224b75643713a6f59598eb94aae473d1ec3e9dd500c40e28017bec1f2d50f27f182a01ed7 SHA512 17c0da4599ae1c111ff1ac3069bbb7b613175253a13086c1d564e0ab268317e6249daa3453d686379b3c29cc5cd76a74c2e6654bed8326ee1c8f46e40cbb4888
+DIST teamviewer_15.3.2682_amd64.tar.xz 13066268 BLAKE2B 701a1c53486b186ebdeee8c4611aba5a96155345e2aa484c8aa1c917d6ef12297ae45946604ba23332e3ce40ec60ea5f85b272289630dc27782122b7c4bd87f2 SHA512 27ac18336339406d7aec30a8765ca61fad45756580e82cb506b52b9fb6f94aea96c67065750c2573430704247be93dca757526a97a7d9b41ade9c88fb66dd267
+DIST teamviewer_15.3.2682_i386.tar.xz 13602852 BLAKE2B 4a3ec9062dd2c670395953bdcc5beb923e37ed00ee315c1a051d10b15e16dfe9fcf00f6b1308180a007257edff931c9a210da4b8520963f2ef0df9406e27b9e8 SHA512 bc599059f5d2b9178db39c1d9cb55303493bd734642bc0aecceb8bbe025056a4a61a50055cfb4ed5841787bdf41a6c544603cde13a724f737677d0710157f077
diff --git a/net-misc/teamviewer/teamviewer-15.3.2682.ebuild b/net-misc/teamviewer/teamviewer-15.3.2682.ebuild
new file mode 100644 (file)
index 0000000..3441ace
--- /dev/null
@@ -0,0 +1,136 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN=${PN}${PV/\.*}
+inherit desktop gnome2-utils systemd
+
+DESCRIPTION="All-In-One Solution for Remote Access and Support over the Internet"
+HOMEPAGE="https://www.teamviewer.com"
+SRC_URI="amd64? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_amd64.tar.xz )
+               x86? ( https://dl.tvcdn.de/download/linux/version_${PV/\.*}x/${PN}_${PV}_i386.tar.xz )"
+
+LICENSE="TeamViewer MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+IUSE=""
+
+DEPEND="sys-apps/sed"
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtdeclarative:5
+       dev-qt/qtgui:5
+       dev-qt/qtnetwork:5
+       dev-qt/qtquickcontrols:5
+       dev-qt/qtwebkit:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       sys-apps/dbus
+       !sys-auth/consolekit
+"
+
+# For consolekit incompatibility see https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956
+
+RESTRICT="bindist mirror"
+
+# Silence QA messages
+QA_PREBUILT="opt/${MY_PN}/*"
+
+S="${WORKDIR}"/teamviewer
+
+src_prepare() {
+       default
+
+       # Switch operation mode from 'portable' to 'installed'
+       sed -e "s/TAR_NI/TAR_IN/g" -i tv_bin/script/tvw_config || die
+
+       sed -e "/^ExecStart/s/${PN}/${MY_PN}/" \
+               -i tv_bin/script/teamviewerd.service || die
+}
+
+src_install() {
+       local dst="/opt/${MY_PN}" # install destination
+
+       # Quirk:
+       # Remove Intel 80386 32-bit ELF binary 'libdepend' present in all
+       # archives. It will trip the 'emerge @preserved-libs' logic on amd64
+       # when changing the ABI of one of its dependencies. According to the
+       # TeamViewer devs, this binary is an unused remnant of previous Wine-
+       # based builds and will be removed in future releases anyway
+       rm tv_bin/script/libdepend
+
+       insinto ${dst}
+       doins -r tv_bin
+
+       # Set permissions for executables and libraries
+       for exe in $(find tv_bin -type f -executable -or -name '*.so'); do
+               fperms 755 ${dst}/${exe}
+       done
+
+       # No slotting here, binary expects this service path
+       newinitd "${FILESDIR}"/teamviewerd15.init teamviewerd
+       systemd_dounit tv_bin/script/teamviewerd.service
+
+       insinto /usr/share/dbus-1/services
+       doins tv_bin/script/com.teamviewer.TeamViewer.service
+       doins tv_bin/script/com.teamviewer.TeamViewer.Desktop.service
+
+       insinto /usr/share/polkit-1/actions
+       doins tv_bin/script/com.teamviewer.TeamViewer.policy
+
+       for size in 16 24 32 48 256; do
+               newicon -s ${size} tv_bin/desktop/teamviewer_${size}.png TeamViewer.png
+       done
+
+       # Install documents (NOTE: using 'dodoc -r doc' instead of loop will
+       # have the undesired result of installing subdirectory 'doc' in /usr/
+       # share/doc/teamviewer-<version>)
+       for doc in $(find doc -type f); do
+               dodoc ${doc}
+       done
+
+       keepdir /etc/${MY_PN}
+       dosym ../../etc/${MY_PN} ${dst}/config
+
+       # Create directory and symlink for log files (NOTE: according to Team-
+       # Viewer devs, all paths are hard-coded in the binaries; therefore
+       # using the same path as the DEB/RPM archives, i.e. '/var/log/teamviewer
+       # <major-version>')
+       keepdir /var/log/${MY_PN}
+       dosym ../../var/log/${MY_PN} ${dst}/logfiles
+
+       dodir /opt/bin
+       dosym ${dst}/tv_bin/teamviewerd /opt/bin/teamviewerd
+       dosym ${dst}/tv_bin/script/teamviewer /opt/bin/teamviewer
+
+       make_desktop_entry teamviewer "TeamViewer ${SLOT}" TeamViewer
+}
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+
+       elog "Please note that parallel installation of multiple versions of"
+       elog "TeamViewer is currently not supported at runtime. Bug #621818"
+       elog ""
+       elog "Before using TeamViewer, you need to start its daemon:"
+       elog "OpenRC:"
+       elog "# /etc/init.d/teamviewerd start"
+       elog "# rc-update add teamviewerd default"
+       elog
+       elog "Systemd:"
+       elog "# systemctl start teamviewerd.service"
+       elog "# systemctl enable teamviewerd.service"
+       elog
+       elog "To display additional command line options simply run:"
+       elog "$ teamviewer help"
+       elog
+       elog "Most likely TeamViewer will work normally only on systems with systemd"
+       elog "or elogind. See this thread for additional info:"
+       elog "https://forums.gentoo.org/viewtopic-p-8332956.html?sid=3cc21e5a27935e38975ee85bf03317ae#8332956"
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}