dev-python/pycairo: version bump to 1.18.1
authorTim Harder <radhermit@gentoo.org>
Tue, 23 Apr 2019 21:11:13 +0000 (16:11 -0500)
committerTim Harder <radhermit@gentoo.org>
Tue, 23 Apr 2019 21:13:15 +0000 (16:13 -0500)
Closes: https://bugs.gentoo.org/682878

Signed-off-by: Tim Harder <radhermit@gentoo.org>
dev-python/pycairo/Manifest
dev-python/pycairo/pycairo-1.18.1.ebuild [new file with mode: 0644]

index f9e41f94403f9fbb0e6f9ba747934915f31a6c73..719ee186422a10e699c5c422c57f2425b92d1ce3 100644 (file)
@@ -1,2 +1,3 @@
 DIST pycairo-1.16.3.tar.gz 188610 BLAKE2B 71034891bae636e23379a3fdc49c9163cff61183fe46c4027bbad3206e72255e60081dbc3cb02808d5c3840b618f6c12f8106ca5a08ddb226a65917ba2da390c SHA512 d60978f85eb0430f2038b0e7d0bce23602e8c180a7611eea424fd8bc3cdd8ce249af364abd0e77ab3b7ab439761721cba5c2398f51af2a89add3fb7fda8aa5db
 DIST pycairo-1.17.0.tar.gz 192182 BLAKE2B b7a4db8258b03b89878fca6b5e27bb9037b74b1792ded23edfe38a0aa5e9ba5003bbac2c8623a6ace8033960c3199b307dcb689650e21ba2df0d81a36a71b6cf SHA512 c073f04d92c9a577f7dcea8d46335751ebd896a65e682e99e4453877d8ba2cadad4437f4ceb1ce8c05eb87d5757a2bd78ac2549e63e38720f4c9276e6f70bdd5
+DIST pycairo-1.18.1.tar.gz 200610 BLAKE2B 47e707f3481d816e9fcd72d169d7ab9210f746396a45a6c9cdac946b4dca9529515ebe1a288d985eed659ff23488bec2cf3e0fb8d11c160349530871ed05881f SHA512 fef6b0d863d45a182a1ba671ddc4f6cb15745447cdaed3e1efeb05fad97f02aa0a56698517648a942bde263d74e06ad7781bcf487757aeb3b124ef64dc525024
diff --git a/dev-python/pycairo/pycairo-1.18.1.ebuild b/dev-python/pycairo/pycairo-1.18.1.ebuild
new file mode 100644 (file)
index 0000000..c45b52a
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy{,3} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND="
+       >=x11-libs/cairo-1.13.1[svg]
+"
+DEPEND="${RDEPEND}
+       doc? ( dev-python/sphinx )
+       test? (
+               dev-python/pytest[${PYTHON_USEDEP}]
+               dev-python/hypothesis[${PYTHON_USEDEP}]
+       )
+"
+
+python_compile_all() {
+       if use doc; then
+               sphinx-build docs -b html _build/html || die
+       fi
+}
+
+python_test() {
+       esetup.py test
+}
+
+python_install() {
+       distutils-r1_python_install \
+               install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+       use doc && local HTML_DOCS=( _build/html/. )
+
+       if use examples; then
+               dodoc -r examples
+       fi
+
+       distutils-r1_python_install_all
+}