dev-python/pytest-aiohttp: 0.3.0-r1 revbump to require pytest-5.4
authorZac Medico <zmedico@gentoo.org>
Mon, 4 May 2020 01:51:40 +0000 (18:51 -0700)
committerZac Medico <zmedico@gentoo.org>
Mon, 4 May 2020 01:54:45 +0000 (18:54 -0700)
Solves this issue:

/usr/lib64/python3.6/site-packages/pytest_asyncio/plugin.py:39: in pytest_pycollect_makeitem
    item = pytest.Function.from_parent(collector, name=name)
E   AttributeError: type object 'Function' has no attribute 'from_parent'

See: https://github.com/gentoo/gentoo/pull/15435#discussion_r412989852
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Zac Medico <zmedico@gentoo.org>
dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild b/dev-python/pytest-aiohttp/pytest-aiohttp-0.3.0-r1.ebuild
new file mode 100644 (file)
index 0000000..733b6f0
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="pytest plugin for aiohttp support"
+HOMEPAGE="https://github.com/aio-libs/pytest-aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE=""
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+RDEPEND="
+       ${CDEPEND}
+       >=dev-python/pytest-5.4[${PYTHON_USEDEP}]
+       >=dev-python/aiohttp-0.22.0[${PYTHON_USEDEP}]
+"