dev-util/buildbot-console-view: Re-add the 0.9.0_p1 release due to a regression in...
authorBrian Dolbec <dolsen@gentoo.org>
Thu, 2 Feb 2017 00:12:43 +0000 (16:12 -0800)
committerBrian Dolbec <dolsen@gentoo.org>
Thu, 2 Feb 2017 00:22:53 +0000 (16:22 -0800)
Package-Manager: Portage-2.3.3_p38, Repoman-2.3.1_p31

dev-util/buildbot-console-view/Manifest
dev-util/buildbot-console-view/buildbot-console-view-0.9.0_p1.ebuild [new file with mode: 0644]

index 6bc08755d3cbe3ac1bc7907d11cacac55006e6b3..f443e25e536ed40b08d60969ffe10922d7b39cea 100644 (file)
@@ -1,3 +1,4 @@
+DIST buildbot-console-view-0.9.0.post1.tar.gz 630459 SHA256 1415fb5afaa5a450a38349ce799190de34749449f1147ae42b6adf5ccfca8735 SHA512 c209c8dd320df2a7a9ab8bd8276a081c981981645ca85511320e5dc755957623cc051feb57904c5208e6f7e2b9f7c4ac6f204c574445cdff643685a2d5dafe17 WHIRLPOOL c81860f92bc6d55a5fa925d2b415ad640f4150573abfde878cf3e02c8f7cecba60de6e8d87571b8dd8f6d0d7ae24fcf29afbce532bb517e90f93644f4c80ec57
 DIST buildbot-console-view-0.9.1.tar.gz 630486 SHA256 028288d2ba8f7c79043c8b0751a53cfedf50f3134dbf57740d310dc708f71cef SHA512 d5936c0494e626ad8db5b1f75994978805d0e65d57b9c4bcce7b1584f32699b4ca2023504b647b54f91ab669e084b7d18973060b512a316808cd892aca2e8fdd WHIRLPOOL 7476cb96e63da87953a6602ceca3aa75eaa0cb6d10e3d49871d333c476b185a068a0fe17ed07d9715ad7c148d686701a702a5366fdf05d96149a6ffb49ae5839
 DIST buildbot-console-view-0.9.2.tar.gz 630903 SHA256 a5acb36e20410bd8fe7a6a34c3afd83115e80651f92f1705a0641e526344e74a SHA512 6b1e05b7b846ecd5cd0d1f091c5cb2f3fe9a7cb6db5651ad406cf7f62fc04ebe68390b459fab78c166b864305135dee7f982f1fbc02ec67060ac3d64c0b90edc WHIRLPOOL c3796d9b60149592d2c0c1c92f91c11039f47fb0260e3ce549b48f251637c0a49a6b83c69b71383838984fdf6b4aeab3508a93b8303c14bada2de0d87cc4d4e7
 DIST buildbot-console-view-0.9.3.tar.gz 631462 SHA256 b389b4024e52824463e696d3ed9a56de8ea5de60abb01ddbb6e2f402ea547fe6 SHA512 0fc51252e323917f64f175ee2cfd46bdab7dc07a921d0fb74c0b5828cc5212ef5f5d2ae43c1f1fe5e2c32a0dab19a52d6bb7c7bb3ce50bdfdb18af02eaf4de82 WHIRLPOOL 63ad18e39c228226ce2ab5441785b013051c732738e54190c214a0a35476fc78e0f5b3c731ecce520f5920777bf728f20e2f0a42615ea9a4049c6f7fab4956df
diff --git a/dev-util/buildbot-console-view/buildbot-console-view-0.9.0_p1.ebuild b/dev-util/buildbot-console-view/buildbot-console-view-0.9.0_p1.ebuild
new file mode 100644 (file)
index 0000000..8870a30
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_REQ_USE="sqlite"
+PYTHON_COMPAT=( python2_7 )
+
+EGIT_REPO_URI="git://github.com/buildbot/buildbot.git"
+
+[[ ${PV} == *9999 ]] && inherit git-r3
+inherit distutils-r1
+
+DESCRIPTION="Buildbot console-view plugin"
+HOMEPAGE="http://trac.buildbot.net/ https://github.com/buildbot/buildbot http://pypi.python.org/pypi/buildbot"
+
+MY_V="0.9.0.post1"
+MY_P="${PN}-${MY_V}"
+[[ ${PV} == *9999 ]] || SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+if [[ ${PV} == *9999 ]]; then
+       KEYWORDS=""
+else
+       KEYWORDS="~amd64"
+fi
+
+RDEPEND="
+       ~dev-util/buildbot-${PV}[${PYTHON_USEDEP}]
+       dev-python/mock[${PYTHON_USEDEP}]
+       ~dev-util/buildbot-www-${PV}[${PYTHON_USEDEP}]
+"
+
+DEPEND="${RDEPEND}
+       >=dev-python/setuptools-21.2.1[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_P}"
+#[[ ${PV} == *9999 ]] && S=${S}/www/base
+
+python_install_all() {
+       distutils-r1_python_install_all
+}