dev-libs/9libs: Revert addition of USE=X
authorJeroen Roovers <jer@gentoo.org>
Sun, 27 Jan 2019 11:23:48 +0000 (12:23 +0100)
committerJeroen Roovers <jer@gentoo.org>
Sun, 27 Jan 2019 11:25:46 +0000 (12:25 +0100)
libXg is built regardless of whether --with-x is passed.

Bug: https://bugs.gentoo.org/675418
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
dev-libs/9libs/9libs-1.0-r4.ebuild

index 84c7b9323a14b4adbce6f28a24499662d3f49510..8e9ba36eccd23e7a711f6bbab929916ddbd24c67 100644 (file)
@@ -11,13 +11,11 @@ SRC_URI="https://www.netlib.org/research/9libs/${P}.tar.bz2"
 LICENSE="PLAN9"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
-IUSE="static-libs X"
+IUSE="static-libs"
 
 DEPEND="
-       X? (
-               >=x11-libs/libX11-1.0.0[static-libs?]
-               >=x11-libs/libXt-1.0.0[static-libs?]
-       )
+       >=x11-libs/libX11-1.0.0[static-libs?]
+       >=x11-libs/libXt-1.0.0[static-libs?]
 "
 RDEPEND="
        ${DEPEND}
@@ -39,9 +37,9 @@ src_configure() {
 
        econf \
                $(use_enable static-libs static) \
-               $(use_with X x) \
                --enable-shared \
-               --includedir=/usr/include/9libs
+               --includedir=/usr/include/9libs \
+               --with-x
 }
 
 src_install() {