dev-python/pyrqlite: Sync the live ebuild
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 11:41:20 +0000 (13:41 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Apr 2020 12:50:48 +0000 (14:50 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pyrqlite/pyrqlite-9999.ebuild

index 342b0c8e9e27a87d7e1f74d5188c479eb47085e2..4ad296a7f2cd07d0d0f4d2925abbc04d6fc39eec 100644 (file)
@@ -17,22 +17,10 @@ HOMEPAGE="https://github.com/rqlite/pyrqlite"
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS=""
-IUSE="test"
-RESTRICT="!test? ( test )"
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-cov[${PYTHON_USEDEP}]
-               dev-python/pylint[${PYTHON_USEDEP}]
-       )"
+distutils_enable_tests pytest
 
 src_prepare() {
        sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
        distutils-r1_src_prepare
 }
-
-python_test() {
-       esetup.py test || die "tests failed"
-       esetup.py lint -f text -E || die "pylint failed"
-}