dev-perl/Time-Format: EAPI6 + tests
authorKent Fredric <kentnl@gentoo.org>
Fri, 16 Mar 2018 08:48:29 +0000 (21:48 +1300)
committerKent Fredric <kentnl@gentoo.org>
Fri, 16 Mar 2018 08:49:02 +0000 (21:49 +1300)
- EAPI6ify
- Fix and enable tests

Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild [new file with mode: 0644]
dev-perl/Time-Format/files/Time-Format-1.12-datetimetest.patch [new file with mode: 0644]
dev-perl/Time-Format/files/Time-Format-1.12-nosig.patch [new file with mode: 0644]

diff --git a/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild b/dev-perl/Time-Format/Time-Format-1.120.0-r1.ebuild
new file mode 100644 (file)
index 0000000..a42be47
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+DIST_AUTHOR=ROODE
+DIST_VERSION=1.12
+inherit perl-module
+
+DESCRIPTION="Easy-to-use date/time formatting"
+LICENSE="Time-Format"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+RDEPEND="
+       dev-perl/Date-Manip
+       >=virtual/perl-Time-Local-1.70.0
+"
+DEPEND="${RDEPEND}
+       >=dev-perl/Module-Build-0.400.0
+       test? ( >=virtual/perl-Test-Simple-0.400.0 )
+"
+PATCHES=(
+       "${FILESDIR}/${PN}-1.12-datetimetest.patch"
+       "${FILESDIR}/${PN}-1.12-nosig.patch"
+)
+PERL_RM_FILES=( "t/0-signature.t" "SIGNATURE" )
+
+src_configure() {
+       export TZ=UTC # https://rt.cpan.org/Public/Bug/Display.html?id=85001
+       perl-module_src_configure
+}
diff --git a/dev-perl/Time-Format/files/Time-Format-1.12-datetimetest.patch b/dev-perl/Time-Format/files/Time-Format-1.12-datetimetest.patch
new file mode 100644 (file)
index 0000000..b43f685
--- /dev/null
@@ -0,0 +1,117 @@
+From 83aaff839cf3b6788d95a253bb099992b366136d Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 16 Mar 2018 21:09:54 +1300
+Subject: Disable auto-probes for Date-Manip
+
+These are currently fragile and broken, and ultimately unnecessary
+on Gentoo (because we have the luxury of forcing a TZ, and if
+Date::Manip still doesn't work, that's a bigger bug we care about )
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=85001
+---
+ t/doc.t   | 15 ---------------
+ t/funcs.t | 14 --------------
+ t/manip.t | 17 -----------------
+ 3 files changed, 46 deletions(-)
+
+diff --git a/t/doc.t b/t/doc.t
+index c5bfe6f..b9ce2af 100755
+--- a/t/doc.t
++++ b/t/doc.t
+@@ -9,19 +9,6 @@ BEGIN { $Time::Format::NOXS = 1 }
+ BEGIN { use_ok 'Time::Format', qw(:all) }\r
+ my $tl_notok;\r
+ BEGIN { $tl_notok = eval('use Time::Local; 1')? 0 : 1 }\r
+-my $dm_notok;\r
+-my $dm_notz;\r
+-BEGIN\r
+-{\r
+-    $dm_notok = eval('use Date::Manip (); 1')? 0 : 1;\r
+-    unless ($dm_notok)\r
+-    {\r
+-        # If Date::Manip can't determine the time zone, it'll bomb out of the tests.\r
+-        $dm_notz = eval('Date::Manip::Date_TimeZone (); 1')? 0 : 1;\r
+-    }\r
+-    delete $INC{'Date/Manip.pm'};\r
+-    %Date::Manip:: = ();\r
+-}\r
\r
+ # Were all variables imported? (3)\r
+ is ref tied %time,     'Time::Format'   =>  '%time imported';\r
+@@ -83,8 +70,6 @@ SKIP:
+     # manip tests (3)\r
+     SKIP:\r
+     {\r
+-        skip 'Date::Manip not available',             3  if $dm_notok;\r
+-        skip 'Date::Manip cannot determine timezone', 3  if $dm_notz;\r
+         is $manip{'%m/%d/%Y',"epoch $t"},                       '06/05/2003'    => 'Example 13';\r
+         is $manip{'%m/%d/%Y','first monday in November 2000'},  '11/06/2000'    => 'Example 14';\r
+         is qq[$time{'yyyymmdd',$manip{'%s',"epoch $t"}}],       '20030605'      => 'Example 15';\r
+diff --git a/t/funcs.t b/t/funcs.t
+index 1e5bdb6..88f3fdc 100755
+--- a/t/funcs.t
++++ b/t/funcs.t
+@@ -13,18 +13,6 @@ BEGIN {
+     delete $INC{'POSIX.pm'};\r
+     %POSIX:: = ();\r
+ }\r
+-my $manip_bad;\r
+-my $manip_notz;\r
+-BEGIN {\r
+-    $manip_bad = eval('use Date::Manip (); 1')? 0 : 1;\r
+-    unless ($manip_bad)\r
+-    {\r
+-        # If Date::Manip can't determine the time zone, it'll bomb out of the tests.\r
+-        $manip_notz = eval ('Date::Manip::Date_TimeZone (); 1')? 0 : 1;\r
+-    }\r
+-    delete $INC{'Date/Manip.pm'};\r
+-    %Date::Manip:: = ();\r
+-}\r
\r
+ # Get day/month names in current locale\r
+ my ($Thursday, $Thu, $June, $Jun);\r
+@@ -71,8 +59,6 @@ SKIP:
+     # time_manip tests (6)\r
+     SKIP:\r
+     {\r
+-        skip 'Date::Manip not available',             6 if $manip_bad;\r
+-        skip 'Date::Manip cannot determine timezone', 6 if $manip_notz;\r
+         my $m = 'first thursday in june 2003';\r
+         is time_manip('%Y',$m),      '2003'      => 'year';\r
+         is time_manip('%d',$m),      '05'        => 'day of month';\r
+diff --git a/t/manip.t b/t/manip.t
+index 763ad59..6f94607 100755
+--- a/t/manip.t
++++ b/t/manip.t
+@@ -5,28 +5,11 @@ use Test::More tests => 6;
\r
+ BEGIN { $Time::Format::NOXS = 1 }\r
+ BEGIN { use_ok 'Time::Format', qw(%manip) }\r
+-my $manip_bad;\r
+-BEGIN\r
+-{\r
+-    unless (eval 'use Date::Manip (); 1')\r
+-    {\r
+-        $manip_bad = 'Date::Manip is not available';\r
+-    }\r
+-    else\r
+-    {\r
+-        # If Date::Manip can't determine the time zone, it'll bomb out of the tests.\r
+-        $manip_bad = 'Date::Manip cannot determine time zone'\r
+-            unless eval 'Date::Manip::Date_TimeZone(); 1';\r
+-    }\r
+-    delete $INC{'Date/Manip.pm'};\r
+-    %Date::Manip:: = ();\r
+-}\r
\r
+ my $t = 'first thursday in june 2003';\r
\r
+ SKIP:\r
+ {\r
+-    skip $manip_bad, 5 if $manip_bad;\r
+     is $manip{'%Y',$t},      '2003'      => 'year';\r
+     is $manip{'%d',$t},      '05'        => 'day of month';\r
+     is $manip{'%D',$t},      '06/05/03'  => '%D';\r
+-- 
+2.16.2
+
diff --git a/dev-perl/Time-Format/files/Time-Format-1.12-nosig.patch b/dev-perl/Time-Format/files/Time-Format-1.12-nosig.patch
new file mode 100644 (file)
index 0000000..ccb11b8
--- /dev/null
@@ -0,0 +1,91 @@
+From 24b17d6a4787db19888cda208197539c324b257f Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Fri, 16 Mar 2018 21:18:37 +1300
+Subject: Kill signature code
+
+Invalidated anyway due to other patches, and non-critical on Gentoo
+due to many other layers of integrity checks.
+---
+ Build.PL        |  2 --
+ MANIFEST        |  3 ---
+ META.json       |  1 -
+ META.yml        |  1 -
+ Makefile.PL     |  1 -
+ SIGNATURE       | 59 ---------------------------------------------------------
+ t/0-signature.t | 26 -------------------------
+ 7 files changed, 93 deletions(-)
+ delete mode 100644 SIGNATURE
+ delete mode 100755 t/0-signature.t
+
+diff --git a/Build.PL b/Build.PL
+index faed77f..6541305 100755
+--- a/Build.PL
++++ b/Build.PL
+@@ -29,9 +29,7 @@ my $builder = Module::Build->new(
+                           'Time::HiRes'       => 0,\r
+                           'DateTime'          => 0,\r
+                           'Date::Manip'       => 0,\r
+-                          'Module::Signature' => 0,\r
+                          },\r
+-    sign               => 1,\r
+     add_to_cleanup     => [ 'Time-Format-*' ],\r
+ );\r
\r
+diff --git a/MANIFEST b/MANIFEST
+index e1aeeb9..fd31290 100755
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -6,11 +6,9 @@ META.json
+ META.yml\r
+ Makefile.PL\r
+ README\r
+-SIGNATURE\r
+ lib/Time/Format.pm\r
+ quickref.ps\r
+ quickref.txt\r
+-t/0-signature.t\r
+ t/1-load.t\r
+ t/DateManip.t\r
+ t/DateTime.t\r
+@@ -35,4 +33,3 @@ t/xs_funcs.t
+ t/xs_locale.t\r
+ t/xs_quot.t\r
+ t/xs_time.t\r
+-SIGNATURE    Added here by Module::Build
+diff --git a/META.json b/META.json
+index cdfee24..e57c760 100644
+--- a/META.json
++++ b/META.json
+@@ -29,7 +29,6 @@
+             "Date::Manip" : 0,
+             "DateTime" : 0,
+             "I18N::Langinfo" : 0,
+-            "Module::Signature" : 0,
+             "POSIX" : 0,
+             "Time::HiRes" : 0
+          },
+diff --git a/META.yml b/META.yml
+index 2efa55e..318c0ff 100644
+--- a/META.yml
++++ b/META.yml
+@@ -21,7 +21,6 @@ recommends:
+   Date::Manip: 0
+   DateTime: 0
+   I18N::Langinfo: 0
+-  Module::Signature: 0
+   POSIX: 0
+   Time::HiRes: 0
+ requires:
+diff --git a/Makefile.PL b/Makefile.PL
+index 7d3059e..14903ab 100755
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -13,5 +13,4 @@ WriteMakefile (
+     ($] >= 5.005 ?    ## Add these new keywords supported since 5.005\r
+       (ABSTRACT_FROM => 'lib/Time/Format.pm', # retrieve abstract from module\r
+        AUTHOR     => 'Eric Roode <roode@cpan.org>') : ()),\r
+-    (MM->can('signature_target')? (SIGN => 1) : ()),\r
+ );\r
+-- 
+2.16.2
+