media-libs/alure: add patch to fix build with USE="fluidsynth"
authorJoshua Clayton <stillcompiling@gmail.com>
Sun, 5 Jun 2016 16:32:52 +0000 (02:32 +1000)
committerMichael Palimaka <kensington@gentoo.org>
Sun, 5 Jun 2016 16:33:54 +0000 (02:33 +1000)
Gentoo-bug: 500164

Package-Manager: portage-2.3.0_rc1

media-libs/alure/alure-1.2.ebuild
media-libs/alure/files/alure-1.2-include-unistd.patch [new file with mode: 0644]

index 3d694ae997704a79800aac1e1d417ac930d2fb65..8f07f4e81ab018df38f7ad5e0a2754c8d8083393 100644 (file)
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
 EAPI=4
-inherit cmake-utils
+inherit cmake-utils eutils
 
 DESCRIPTION="The OpenAL Utility Toolkit"
 HOMEPAGE="http://kcat.strangesoft.net/alure.html"
@@ -24,6 +24,7 @@ RDEPEND=">=media-libs/openal-1.1
 DEPEND="${RDEPEND}"
 
 src_prepare() {
+       epatch "${FILESDIR}/${P}-include-unistd.patch"
        sed -i -e "/DESTINATION/s:doc/alure:doc/${PF}:" CMakeLists.txt || die
 }
 
diff --git a/media-libs/alure/files/alure-1.2-include-unistd.patch b/media-libs/alure/files/alure-1.2-include-unistd.patch
new file mode 100644 (file)
index 0000000..b2db3dc
--- /dev/null
@@ -0,0 +1,13 @@
+Gentoo-bug: 500164
+
+--- a/src/codec_fluidsynth.cpp
++++ b/src/codec_fluidsynth.cpp
+@@ -30,6 +30,8 @@
+ #ifdef _WIN32
+ #include <io.h>
++#else
++#include <unistd.h>
+ #endif
+ #include <istream>