dev-perl/WWW-Mechanize-FormFiller: Bump to version 0.120.0 re bug #633482
authorKent Fredric <kentnl@gentoo.org>
Wed, 21 Mar 2018 02:16:57 +0000 (15:16 +1300)
committerKent Fredric <kentnl@gentoo.org>
Wed, 21 Mar 2018 02:17:31 +0000 (15:17 +1300)
- EAPI6
- Fix problematic incorrect dependency conditional now long redundant
  (bug #633482)
- Enable parallel tests

Upstream:
- Kill user-side author-testing (<3)

Bug: https://bugs.gentoo.org/633482
Package-Manager: Portage-2.3.24, Repoman-2.3.6

dev-perl/WWW-Mechanize-FormFiller/Manifest
dev-perl/WWW-Mechanize-FormFiller/WWW-Mechanize-FormFiller-0.120.0.ebuild [new file with mode: 0644]

index 56c2e69cb2f856b18dfc82a57afaef1301004732..048ce4d89a60f48717e0e33250e92ba279c30caf 100644 (file)
@@ -1 +1,2 @@
 DIST WWW-Mechanize-FormFiller-0.11.tar.gz 20157 BLAKE2B 0a8ea2faa5c06afde5049f03a5ce87a8d836d501244a8fdad7ea8f679a799f055905902a7b7ef498b387e8815bf22e9dd8a0d9d015cdd3d98085b273e750595f SHA512 60436af00f910465f5bfe60c55200c4a4301380295cf0ac39979a73c7f8efc78559ffd828fb145970838919beb2f4a99bbf134adb1976f577569a13f1c8e3b02
+DIST WWW-Mechanize-FormFiller-0.12.tar.gz 19930 BLAKE2B 878dde1ba22665c9db295a6353a685e4b6ad252785b1993ef0498b32863583d0a72bf500e58298c4a463e511bc918e476fb5f09e0d1d8ca4beea7fc8c4b7a17a SHA512 87db40c49daf6955c8d42b4bd61f4cf4b1f08782ef48789d636ca81881bd000b46d52fb293792918e457aa46845e766d3685d4c3c6d14dd1875b629d6f9f0999
diff --git a/dev-perl/WWW-Mechanize-FormFiller/WWW-Mechanize-FormFiller-0.120.0.ebuild b/dev-perl/WWW-Mechanize-FormFiller/WWW-Mechanize-FormFiller-0.120.0.ebuild
new file mode 100644 (file)
index 0000000..d3536c5
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=CORION
+DIST_VERSION=0.12
+inherit perl-module
+
+DESCRIPTION="Framework to automate HTML forms"
+
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+       >=dev-perl/Data-Random-0.50.0
+       dev-perl/HTML-Form
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               dev-perl/Test-MockObject
+               virtual/perl-Test-Simple
+       )
+"